summaryrefslogtreecommitdiff
path: root/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-04-03 14:54:24 -0500
committerJohn Klug <john.klug@multitech.com>2017-05-23 15:21:54 -0500
commit0f2dca7de250ebb262e4d6e305b15008cc354281 (patch)
tree5d9b800a697449daef6db96c60ecce82b10e7b5a /recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb
parent18ce886647f912cc77cd1f78236061f9ba0b5db0 (diff)
downloadmeta-mlinux-0f2dca7de250ebb262e4d6e305b15008cc354281.tar.gz
meta-mlinux-0f2dca7de250ebb262e4d6e305b15008cc354281.tar.bz2
meta-mlinux-0f2dca7de250ebb262e4d6e305b15008cc354281.zip
make ruby-sqlite3 compatible with new ruby/sqlite3
Diffstat (limited to 'recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb')
-rw-r--r--recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb b/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb
deleted file mode 100644
index d0cb2b6..0000000
--- a/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "Ruby bindings for the SQLite3 embedded database"
-HOMEPAGE = "https://github.com/luislavena/sqlite3-ruby"
-LICENSE = "custom-freely-distributable"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f24ce0d57c8f8576a36e2803d35bcfec"
-SECTION = "console/utils"
-PRIORITY = "optional"
-
-DEPENDS = "ruby sqlite3"
-
-PR = "r0"
-
-SRC_URI = "git://github.com/luislavena/sqlite3-ruby.git;tag=v${PV};protocol=git"
-
-S = "${WORKDIR}/git"
-B = "${S}"
-
-do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} -Iext/sqlite3 -Iext/native -I${STAGING_INCDIR}/ruby-1.9.1 -I${STAGING_INCDIR}/ruby-1.9.1/arm-linux-eabi -c ext/sqlite3/*.c
- ${CC} ${CFLAGS} ${LDFLAGS} --shared -o ext/sqlite3/sqlite3_native.so *.o -lsqlite3
-}
-
-do_install() {
- install -d ${D}${libdir}/ruby ${D}${libdir}/ruby/sqlite3
- install lib/sqlite3.rb ${D}${libdir}/ruby/sqlite3.rb
- install lib/sqlite3/* ext/sqlite3/sqlite3_native.so -t ${D}${libdir}/ruby/sqlite3
-}
-
-FILES_${PN} = "${libdir}/ruby/sqlite3*"
-FILES_${PN}-dbg += "${libdir}/ruby/sqlite3/.debug*"