summaryrefslogtreecommitdiff
path: root/recipes-production/mfg-tests/mfg-tests_1.0.bb
diff options
context:
space:
mode:
authorSerhii Voloshynov <serhii.voloshynov@globallogic.com>2022-06-08 15:42:59 +0300
committerJohn Klug <john.klug@multitech.com>2022-06-14 12:44:06 -0500
commit6d4348b994c6be26ecceb03c268c1c2daba992b4 (patch)
treec897ec1da65e1ee09650dde181fe99c8f6d9515e /recipes-production/mfg-tests/mfg-tests_1.0.bb
parent91de6c8d8b1f6134f702b078401237df2b442bcc (diff)
downloadmeta-mlinux-6d4348b994c6be26ecceb03c268c1c2daba992b4.tar.gz
meta-mlinux-6d4348b994c6be26ecceb03c268c1c2daba992b4.tar.bz2
meta-mlinux-6d4348b994c6be26ecceb03c268c1c2daba992b4.zip
add test-reset script allowing to test the reset button by TeraTerm script without rebooting
Diffstat (limited to 'recipes-production/mfg-tests/mfg-tests_1.0.bb')
-rw-r--r--recipes-production/mfg-tests/mfg-tests_1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-production/mfg-tests/mfg-tests_1.0.bb b/recipes-production/mfg-tests/mfg-tests_1.0.bb
new file mode 100644
index 0000000..3827551
--- /dev/null
+++ b/recipes-production/mfg-tests/mfg-tests_1.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Reset button test script"
+SECTION = "base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PR = "r1"
+RDEPENDS_${PN} += "bash"
+
+
+SRC_URI = "\
+ file://test-reset.sh \
+"
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/test-reset.sh ${D}${sbindir}/test-reset
+}