summaryrefslogtreecommitdiff
path: root/recipes-navigation
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2021-12-23 08:48:17 -0600
committerJeff Hatch <jhatch@multitech.com>2021-12-23 08:48:17 -0600
commitbe0069adf8794e129cd5b01d4b1052677136d82c (patch)
tree35dc835a889a34809d1721bc1fc7d06db93b3f61 /recipes-navigation
parent1f060beda52daf8ee1d6fab74cad518bec7f1144 (diff)
parentc68d4d88a538f364dfd28db155fc3f2d5e6f3cac (diff)
downloadmeta-mlinux-be0069adf8794e129cd5b01d4b1052677136d82c.tar.gz
meta-mlinux-be0069adf8794e129cd5b01d4b1052677136d82c.tar.bz2
meta-mlinux-be0069adf8794e129cd5b01d4b1052677136d82c.zip
Merge branch 'ap/MTX-4274' into 6
This merge brings in to the 6 branch all the updates for the hardware parts shortage new hardware versions for MTR and Conduit.
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd-3.20/0008-timebase.patch25
-rw-r--r--recipes-navigation/gpsd/gpsd/gpsd-default7
-rw-r--r--recipes-navigation/gpsd/gpsd_3.20.bb1
3 files changed, 33 insertions, 0 deletions
diff --git a/recipes-navigation/gpsd/gpsd-3.20/0008-timebase.patch b/recipes-navigation/gpsd/gpsd-3.20/0008-timebase.patch
new file mode 100644
index 0000000..a61d6b0
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd-3.20/0008-timebase.patch
@@ -0,0 +1,25 @@
+#
+# gpsd 3.20 thinks that 2021 never happened, and we roll back the time 19
+# years. Need to allow for 2021.
+#
+===============================================================================
+diff --git a/timebase.c b/timebase.c
+index 85cfd90..8e08b18 100644
+--- a/timebase.c
++++ b/timebase.c
+@@ -385,6 +385,7 @@ timespec_t gpsd_gpstime_resolv(struct gps_device_t *session,
+ /* sanity check week number, GPS epoch, against leap seconds
+ * Does not work well with regressions because the leap_sconds
+ * could be from the receiver, or from BUILD_LEAPSECONDS. */
++#ifdef YESTERDAY
+ if (0 < session->context->leap_seconds &&
+ 19 > session->context->leap_seconds &&
+ 2180 < week) {
+@@ -395,6 +396,7 @@ timespec_t gpsd_gpstime_resolv(struct gps_device_t *session,
+ "GPS week confusion. Adjusted week %u for leap %d\n",
+ week, session->context->leap_seconds);
+ }
++#endif
+
+ // gcc needs the (time_t)week to not overflow. clang got it right.
+ // if time_t is 32-bits, then still 2038 issues
diff --git a/recipes-navigation/gpsd/gpsd/gpsd-default b/recipes-navigation/gpsd/gpsd/gpsd-default
index a3245a3..4c92ea2 100644
--- a/recipes-navigation/gpsd/gpsd/gpsd-default
+++ b/recipes-navigation/gpsd/gpsd/gpsd-default
@@ -55,6 +55,13 @@ function SET_GPS_SPEED {
((maxtries = 20))
if [[ $(cat /run/config/gpstype) == u-blox ]] ; then
+ # If the U-Blox is connected via USB, it shows
+ # up as using the ACM serial driver. This greatly
+ # simplifies setting up the U-Blox GNSS.
+ if [[ $(readlink $GPS_LINE) =~ ^ttyACM ]] ; then
+ stty -F $GPS_LINE 115200
+ return 0
+ fi
while ((maxtries >= 0)) ; do
((maxtries--))
if ((maxtries % 5 == 0)) ; then
diff --git a/recipes-navigation/gpsd/gpsd_3.20.bb b/recipes-navigation/gpsd/gpsd_3.20.bb
index eeaf0a3..9afe0fe 100644
--- a/recipes-navigation/gpsd/gpsd_3.20.bb
+++ b/recipes-navigation/gpsd/gpsd_3.20.bb
@@ -19,6 +19,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://0006-ubxtimelps.patch \
file://0006-itu_r_tf_460_6.patch \
file://0007-add-gll-vtg.patch \
+ file://0008-timebase.patch \
file://gpsd-default \
file://gpsd \
file://gpsd_ubx_fixed.sh \