summaryrefslogtreecommitdiff
path: root/recipes-navigation
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-12-27 23:58:04 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-12-27 23:58:33 +0200
commit754d0018a92e3b21c61171213c7deb774213b3b1 (patch)
tree01d0f9e51386fddc1b1b655e9e2e1e3edae9503f /recipes-navigation
parent8e3baf6f8b90a9455bee79ce0fb89207ef73e534 (diff)
downloadmeta-mlinux-754d0018a92e3b21c61171213c7deb774213b3b1.tar.gz
meta-mlinux-754d0018a92e3b21c61171213c7deb774213b3b1.tar.bz2
meta-mlinux-754d0018a92e3b21c61171213c7deb774213b3b1.zip
gpsd: enable same gpsd features as in previous revs (ublox, etc.)
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd_3.23.1.bb52
1 files changed, 51 insertions, 1 deletions
diff --git a/recipes-navigation/gpsd/gpsd_3.23.1.bb b/recipes-navigation/gpsd/gpsd_3.23.1.bb
index eebbe15..9af661e 100644
--- a/recipes-navigation/gpsd/gpsd_3.23.1.bb
+++ b/recipes-navigation/gpsd/gpsd_3.23.1.bb
@@ -27,10 +27,11 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez',
PACKAGECONFIG[bluez] = "bluez='true',bluez='false',bluez5"
PACKAGECONFIG[qt] = "qt='yes' qt_versioned=5,qt='no',qtbase"
PACKAGECONFIG[usb] = "usb='true',usb='false',libusb1"
+
+# Remove unneeded features. netfeed is needed by gpsmon
EXTRA_OESCONS = " \
sysroot=${STAGING_DIR_TARGET} \
libQgpsmm='false' \
- debug='false' \
nostrip='true' \
systemd='${SYSTEMD_OESCONS}' \
libdir='${libdir}' \
@@ -38,9 +39,58 @@ EXTRA_OESCONS = " \
udevdir='${nonarch_base_libdir}/udev' \
unitdir='${systemd_system_unitdir}' \
manbuild='false' \
+ debug='true' \
+ strip='false' \
+ chrpath='yes' \
+ ublox='yes' \
+ ubloxtimels='yes' \
+ pps='yes' \
+ gpsd_group='gps' \
+ ntpshm='yes' \
+ prefix='usr' \
+ control_socket='false' \
+ nofloats='yes' \
+ ashtech='false' \
+ earthmate='false' \
+ evermore='false' \
+ fury='false' \
+ fv18='false' \
+ garmin='false' \
+ garmintxt='false' \
+ geostar='false' \
+ greis='false' \
+ itrax='false' \
+ mtk3301='false' \
+ navcom='false' \
+ nmea0183='true' \
+ nmea2000='false' \
+ oncore='false' \
+ sirf='false' \
+ skytraq='false' \
+ superstar2='false' \
+ tnt='false' \
+ tripmate='false' \
+ tsip='false' \
+ ublox='true' \
+ aivdm='false' \
+ gpsclock='false' \
+ isync='false' \
+ ntrip='false' \
+ oceanserver='false' \
+ passthrough='false' \
+ rtcm104v2='false' \
+ rtcm104v3='false' \
+ bluez='false' \
+ ipv6='false' \
+ netfeed='true' \
+ usb='false' \
LINK='${CC}' \
${PACKAGECONFIG_CONFARGS} \
"
+
+
+
+
# This cannot be used, because then chrpath is not found and only static lib is built
# target=${HOST_SYS}