summaryrefslogtreecommitdiff
path: root/recipes-navigation
diff options
context:
space:
mode:
authorSerhii Voloshynov <serhii.voloshynov@globallogic.com>2020-12-14 13:55:22 +0200
committerJohn Klug <john.klug@multitech.com>2021-01-04 13:27:09 -0600
commit66a9d870b72f186b9d749d2084133941780efa79 (patch)
treee9d6d8a74aaa411de41a46cd26024f5a7cc3041d /recipes-navigation
parentf6850471e08f5aa446329ba89b1b5eec129e722a (diff)
downloadmeta-mlinux-66a9d870b72f186b9d749d2084133941780efa79.tar.gz
meta-mlinux-66a9d870b72f186b9d749d2084133941780efa79.tar.bz2
meta-mlinux-66a9d870b72f186b9d749d2084133941780efa79.zip
make gpsd more python3
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd_3.20.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-navigation/gpsd/gpsd_3.20.bb b/recipes-navigation/gpsd/gpsd_3.20.bb
index 9e14b46..2cf7b67 100644
--- a/recipes-navigation/gpsd/gpsd_3.20.bb
+++ b/recipes-navigation/gpsd/gpsd_3.20.bb
@@ -177,7 +177,7 @@ pkg_postrm_${PN}-conf() {
update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
}
-PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils"
+PACKAGES =+ "libgps libgpsd python3-pygps-dbg python3-pygps gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils"
# File does not exist: ${libdir}/libQgpsmm.prl
FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc \
@@ -186,7 +186,7 @@ FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.
FILES_${PN} += "${sbindir}/gpsd_*"
-FILES_python-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"
+FILES_python3-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"
RDEPENDS_${PN} = "gpsd-gpsctl bash"
@@ -215,18 +215,18 @@ FILES_gpspipe = "${bindir}/gpspipe"
SUMMARY_gps-utils = "Utils used for simulating, monitoring,... a GPS"
FILES_gps-utils = "${bindir}/*"
-RDEPENDS_gps-utils = "python-pygps"
+RDEPENDS_gps-utils = "python3-pygps"
-SUMMARY_python-pygps = "Python bindings to gpsd"
-FILES_python-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
+SUMMARY_python3-pygps = "Python bindings to gpsd"
+FILES_python3-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
RDEPENDS_python-pygps = " \
- python-core \
- python-io \
- python-threading \
- python-terminal \
- python-curses \
+ python3-core \
+ python3-io \
+ python3-threading \
+ python3-terminal \
+ python3-curses \
gpsd \
- python-json"
+ python3-json"
RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"