summaryrefslogtreecommitdiff
path: root/recipes-navigation/gpsd/gpsd_3.18.1.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-03-15 17:44:37 -0500
committerJohn Klug <john.klug@multitech.com>2019-03-15 17:44:37 -0500
commitc342cb9ecde8b366cdec3e21af87b0e4746d7078 (patch)
treed4ae07fb942bc450335914a57e7d105e458e0130 /recipes-navigation/gpsd/gpsd_3.18.1.bb
parent4ab23ea883917948fd575ca9dec446af6dee859e (diff)
downloadmeta-mlinux-c342cb9ecde8b366cdec3e21af87b0e4746d7078.tar.gz
meta-mlinux-c342cb9ecde8b366cdec3e21af87b0e4746d7078.tar.bz2
meta-mlinux-c342cb9ecde8b366cdec3e21af87b0e4746d7078.zip
Make gpsd recipe independent of U-Blox and faster time setting with improved gpsd_settime.
Diffstat (limited to 'recipes-navigation/gpsd/gpsd_3.18.1.bb')
-rw-r--r--recipes-navigation/gpsd/gpsd_3.18.1.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-navigation/gpsd/gpsd_3.18.1.bb b/recipes-navigation/gpsd/gpsd_3.18.1.bb
index 021d86a..5793344 100644
--- a/recipes-navigation/gpsd/gpsd_3.18.1.bb
+++ b/recipes-navigation/gpsd/gpsd_3.18.1.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-replacement-native pps-tools"
PROVIDES = "virtual/gpsd"
-PR="m4"
+PR="m5"
EXTRANATIVEPATH += "chrpath-native"
@@ -21,6 +21,8 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://gpsd \
file://gpsd_ubx_fixed.sh \
file://gpsd_ubx_settime.sh \
+ file://gpsd_fixed.sh \
+ file://gpsd_settime.sh \
file://gpsd.rules \
file://gpsd.service \
"
@@ -128,6 +130,9 @@ do_install_append() {
install -d ${D}${sbindir}
install -m 0755 ${WORKDIR}/gpsd_ubx_fixed.sh ${D}${sbindir}/gpsd_ubx_fixed
install -m 0755 ${WORKDIR}/gpsd_ubx_settime.sh ${D}${sbindir}/gpsd_ubx_settime
+ install -m 0755 ${WORKDIR}/gpsd_fixed.sh ${D}${sbindir}/gpsd_fixed
+ install -m 0755 ${WORKDIR}/gpsd_settime.sh ${D}${sbindir}/gpsd_settime
+
#support for udev
install -d ${D}/${sysconfdir}/udev/rules.d
@@ -176,7 +181,7 @@ FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.
${libdir}/libQgpsmm.prl \
${includedir}/gps.h ${includedir}/libgpsmm.h ${includedir}/gps"
-FILES_${PN} += "${sbindir}/gpsd_ubx_fixed ${sbindir}/gpsd_ubx_settime"
+FILES_${PN} += "${sbindir}/gpsd_*"
FILES_python-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"