summaryrefslogtreecommitdiff
path: root/recipes-java
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
committerJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
commite243c30f04c18722dc65effe6d4f275a3f35de46 (patch)
tree807610ce8af0ead02681d6c3cc89d902ec941652 /recipes-java
downloadmeta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.gz
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.bz2
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.zip
initial commit of mLinux layer
Diffstat (limited to 'recipes-java')
-rw-r--r--recipes-java/openjdk/openjdk-7/jvm.cfg43
-rw-r--r--recipes-java/openjdk/openjdk-7_25b30-2.3.12.bbappend6
-rw-r--r--recipes-java/v4l4j/v4l4j-0.9.1/makefile.patch13
-rw-r--r--recipes-java/v4l4j/v4l4j_0.9.1.bb38
4 files changed, 100 insertions, 0 deletions
diff --git a/recipes-java/openjdk/openjdk-7/jvm.cfg b/recipes-java/openjdk/openjdk-7/jvm.cfg
new file mode 100644
index 0000000..5a21e4e
--- /dev/null
+++ b/recipes-java/openjdk/openjdk-7/jvm.cfg
@@ -0,0 +1,43 @@
+# Copyright 2003 Sun Microsystems, Inc. All Rights Reserved.
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This code is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License version 2 only, as
+# published by the Free Software Foundation. Sun designates this
+# particular file as subject to the "Classpath" exception as provided
+# by Sun in the LICENSE file that accompanied this code.
+#
+# This code is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# version 2 for more details (a copy is included in the LICENSE file that
+# accompanied this code).
+#
+# You should have received a copy of the GNU General Public License version
+# 2 along with this work; if not, write to the Free Software Foundation,
+# Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
+#
+#
+# List of JVMs that can be used as an option to java, javac, etc.
+# Order is important -- first in this list is the default JVM.
+# NOTE that this both this file and its format are UNSUPPORTED and
+# WILL GO AWAY in a future release.
+#
+# You may also select a JVM in an arbitrary location with the
+# "-XXaltjvm=<jvm_dir>" option, but that too is unsupported
+# and may not be available in a future release.
+#
+-jamvm ERROR
+-server ERROR
+-client IGNORE
+-hotspot ERROR
+-classic WARN
+-native ERROR
+-green ERROR
+-zero ALIASED_TO -server
+-shark ERROR
+-cacao ERROR
diff --git a/recipes-java/openjdk/openjdk-7_25b30-2.3.12.bbappend b/recipes-java/openjdk/openjdk-7_25b30-2.3.12.bbappend
new file mode 100644
index 0000000..c7a6e78
--- /dev/null
+++ b/recipes-java/openjdk/openjdk-7_25b30-2.3.12.bbappend
@@ -0,0 +1,6 @@
+# provides custom jvm.cfg to set the default JVM
+
+# openjdk-7 recipe is prepending to FILESPATH, so use
+# FILESPATH instead of FILESEXTRAPATH or our file doesn't
+# get picked up
+FILESPATH_prepend := "${THISDIR}/openjdk-7:"
diff --git a/recipes-java/v4l4j/v4l4j-0.9.1/makefile.patch b/recipes-java/v4l4j/v4l4j-0.9.1/makefile.patch
new file mode 100644
index 0000000..52639fa
--- /dev/null
+++ b/recipes-java/v4l4j/v4l4j-0.9.1/makefile.patch
@@ -0,0 +1,13 @@
+Index: v4l4j-0.9.1/src/Makefile
+===================================================================
+--- v4l4j-0.9.1.orig/src/Makefile 2014-09-16 16:52:05.753059188 -0500
++++ v4l4j-0.9.1/src/Makefile 2014-09-16 16:52:15.260916249 -0500
+@@ -51,7 +51,7 @@
+ all: $(LIB)
+
+ $(LIB): $(OBJ)
+- $(LD) $(OBJ) $(LDFLAGS) -o $(LIB)
++ $(CC) $(OBJ) $(LDFLAGS) -o $(LIB)
+
+ test-debug: $(LIBVIDEO_PATH)/lib$(LIBVIDEO_NAME).so
+ $(CC) $(INCLUDES) -DDEBUG -Wall -ggdb -DMAKETEST -c jpeg.c
diff --git a/recipes-java/v4l4j/v4l4j_0.9.1.bb b/recipes-java/v4l4j/v4l4j_0.9.1.bb
new file mode 100644
index 0000000..605c746
--- /dev/null
+++ b/recipes-java/v4l4j/v4l4j_0.9.1.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "A java package to access the Capture interface of the Video4Linux API"
+DEPENDS = "jpeg icedtea6-native libv4l"
+PR = "r0"
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=87212b5f1ae096371049a12f80034f32"
+
+SRC_URI = "http://v4l4j.googlecode.com/files/v4l4j-${PV}.tar.gz \
+ file://makefile.patch \
+ "
+
+SRC_URI[md5sum] = "88756ca604a4701b7c453be24f948a09"
+SRC_URI[sha256sum] = "cb20aad827442960090660d85f9fa24eed9417e732fdefb66e57083df3c88cf7"
+
+export JDK_HOME = "${STAGING_LIBDIR_NATIVE}/jvm/icedtea6-native"
+STAGING_DATADIR_JAVA_NATIVE = "${STAGING_DATADIR_NATIVE}/java"
+
+# run ant with icedtea6-native so things get compiled with java 1.6
+ANT = "${JDK_HOME}/bin/java \
+ -cp ${STAGING_DATADIR_JAVA_NATIVE}/ant.jar:${JDK_HOME}/lib/tools.jar \
+ org.apache.tools.ant.launch.Launcher"
+
+do_compile () {
+ ${ANT} clean all
+}
+
+do_install () {
+ install -d ${D}${libdir}
+ install libvideo/libvideo.so.0 ${D}${libdir}
+
+ install -d ${D}/usr/share/java
+ install v4l4j.jar ${D}/usr/share/java
+
+ install -d ${D}/usr/lib/jni
+ install libv4l4j.so ${D}/usr/lib/jni
+}
+
+FILES_${PN} += "/usr/share/java /usr/lib/jni"
+FILES_${PN}-dbg += "/usr/lib/jni/.debug"