summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-07-29 13:26:59 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:20 +0300
commit30400e029fdf6751d8f0ecc602f65702748e6e82 (patch)
tree53a5ebb1d0c10a21e8dc86b7f84832cf2b9ed897 /recipes-extended
parent5a0fc418e0617126bcb212213e30954c8b1dc02d (diff)
downloadmeta-mlinux-30400e029fdf6751d8f0ecc602f65702748e6e82.tar.gz
meta-mlinux-30400e029fdf6751d8f0ecc602f65702748e6e82.tar.bz2
meta-mlinux-30400e029fdf6751d8f0ecc602f65702748e6e82.zip
Use Openembedded bash
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/bash/bash-4.2/build-tests.patch48
-rw-r--r--recipes-extended/bash/bash-4.2/execute_cmd.patch17
-rw-r--r--recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch26
-rw-r--r--recipes-extended/bash/bash-4.2/run-ptest2
-rw-r--r--recipes-extended/bash/bash-4.2/test-output.patch25
-rw-r--r--recipes-extended/bash/bash.inc50
-rw-r--r--recipes-extended/bash/bash_4.2.bb173
7 files changed, 0 insertions, 341 deletions
diff --git a/recipes-extended/bash/bash-4.2/build-tests.patch b/recipes-extended/bash/bash-4.2/build-tests.patch
deleted file mode 100644
index 0360881..0000000
--- a/recipes-extended/bash/bash-4.2/build-tests.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Add 'ptest' target to Makefile, to run tests without checking dependencies.
-
-Signed-off-by: Anders Roxell <anders.roxell@enea.com>
-Upstream-Status: Pending
----
-diff -uNr a/Makefile.in b/Makefile.in
---- a/Makefile.in 2012-11-06 08:40:07.552403063 +0100
-+++ b/Makefile.in 2012-11-06 11:13:36.958297555 +0100
-@@ -827,20 +827,34 @@
- fi
-
- recho$(EXEEXT): $(SUPPORT_SRC)recho.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)recho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
- zecho$(EXEEXT): $(SUPPORT_SRC)zecho.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)zecho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
- printenv$(EXEEXT): $(SUPPORT_SRC)printenv.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)printenv.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
- xcase$(EXEEXT): $(SUPPORT_SRC)xcase.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)xcase.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
--test tests check: force $(Program) $(TESTS_SUPPORT)
-+test tests check:
-+ @$(MAKE) install-test
-+ @$(MAKE) runtest
-+
-+install-test: buildtest
-+ifeq ($(origin INSTALL_TEST_DIR), undefined)
- @-test -d tests || mkdir tests
- @cp $(TESTS_SUPPORT) tests
-+else
-+ @-test -d $(INSTALL_TEST_DIR) || mkdir -p $(INSTALL_TEST_DIR)
-+ @cp -r $(srcdir)/tests/* $(INSTALL_TEST_DIR)/
-+ @cp $(TESTS_SUPPORT) $(INSTALL_TEST_DIR)
-+endif
-+
-+buildtest: force $(Program) $(TESTS_SUPPORT)
-+
-+runtest:
- @( cd $(srcdir)/tests && \
- PATH=$(BUILD_DIR)/tests:$$PATH THIS_SH=$(THIS_SH) $(SHELL) ${TESTSCRIPT} )
-
diff --git a/recipes-extended/bash/bash-4.2/execute_cmd.patch b/recipes-extended/bash/bash-4.2/execute_cmd.patch
deleted file mode 100644
index 81f8f0a..0000000
--- a/recipes-extended/bash/bash-4.2/execute_cmd.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
---- execute_cmd.c.orig Fri Jun 3 13:34:42 2011
-+++ execute_cmd.c Fri Jun 3 13:36:41 2011
-@@ -2202,7 +2202,11 @@
- /* If the `lastpipe' option is set with shopt, and job control is not
- enabled, execute the last element of non-async pipelines in the
- current shell environment. */
-- if (lastpipe_opt && job_control == 0 && asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
-+ if (lastpipe_opt &&
-+#if defined(JOB_CONTROL)
-+ job_control == 0 &&
-+#endif
-+ asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
- {
- lstdin = move_to_high_fd (0, 0, 255);
- if (lstdin > 0)
diff --git a/recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch b/recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch
deleted file mode 100644
index a9391d6..0000000
--- a/recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-On hosts with FORTIFY_SOURCES, stringize support is required, as it's used by
-the macros to wrap functions (e.g. read and open in unistd.h). Those wrappers
-use the STRING() macro from unistd.h. A header in the bash sources overrides
-the unistd.h macro to 'x' when HAVE_STRINGIZE is not defined, causing the
-wrappers to generate calls to 'xread' and 'xopen', which do not exist,
-resulting in a failure to link.
-
-Assume we have stringize support when cross-compiling, which works around the
-issue.
-
-It may be best for upstream to either give up on supporting compilers without
-stringize support, or to not define STRING() at all when FORTIFY_SOURCES is
-defined, letting the unistd.h one be used, instead.
-
-Upstream-Status: Pending
-
---- bash-4.2.orig/builtins/mkbuiltins.c
-+++ bash-4.2/builtins/mkbuiltins.c
-@@ -28,6 +28,7 @@
- # define HAVE_STDLIB_H
-
- # define HAVE_RENAME
-+# define HAVE_STRINGIZE
- #endif /* CROSS_COMPILING */
-
- #if defined (HAVE_UNISTD_H)
diff --git a/recipes-extended/bash/bash-4.2/run-ptest b/recipes-extended/bash/bash-4.2/run-ptest
deleted file mode 100644
index 8dd3b99..0000000
--- a/recipes-extended/bash/bash-4.2/run-ptest
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-make -k THIS_SH=/bin/bash BUILD_DIR=. runtest
diff --git a/recipes-extended/bash/bash-4.2/test-output.patch b/recipes-extended/bash/bash-4.2/test-output.patch
deleted file mode 100644
index 2b09b7d..0000000
--- a/recipes-extended/bash/bash-4.2/test-output.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Add FAIL/PASS output to test output.
-
-Signed-off-by: Björn Stenberg <bjst@enea.com>
-Upstream-Status: Pending
----
-diff -uNr a/tests/run-all b/tests/run-all
---- a/tests/run-all 1999-10-08 17:07:46.000000000 +0200
-+++ b/tests/run-all 2012-10-27 21:04:18.663331887 +0200
-@@ -22,7 +22,15 @@
- case $x in
- $0|run-minimal|run-gprof) ;;
- *.orig|*~) ;;
-- *) echo $x ; sh $x ;;
-+ *) echo $x
-+ output=`sh $x`
-+ if [ -n "$output" ]; then
-+ echo "$output"
-+ echo "FAIL: $x"
-+ else
-+ echo "PASS: $x"
-+ fi
-+ ;;
- esac
- done
-
diff --git a/recipes-extended/bash/bash.inc b/recipes-extended/bash/bash.inc
deleted file mode 100644
index 64b476f..0000000
--- a/recipes-extended/bash/bash.inc
+++ /dev/null
@@ -1,50 +0,0 @@
-DESCRIPTION = "An sh-compatible command language interpreter."
-HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-SECTION = "base/shell"
-
-DEPENDS = "ncurses bison-native"
-
-inherit autotools gettext update-alternatives ptest
-
-PARALLEL_MAKE = ""
-
-EXTRA_OECONF = "--enable-job-control"
-
-ALTERNATIVE_${PN} = "sh"
-ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
-ALTERNATIVE_TARGET[sh] = "${base_bindir}/bash"
-ALTERNATIVE_PRIORITY = "100"
-
-export AUTOHEADER = "true"
-
-RDEPENDS_${PN}-ptest += "make"
-
-do_configure_prepend () {
- if [ ! -e ${S}/acinclude.m4 ]; then
- cat ${S}/aclocal.m4 > ${S}/acinclude.m4
- fi
-}
-
-do_compile_ptest () {
- oe_runmake buildtest
-}
-
-do_install_append () {
- # Move /usr/bin/bash to /bin/bash, if need
- if [ "${base_bindir}" != "${bindir}" ]; then
- mkdir -p ${D}${base_bindir}
- mv ${D}${bindir}/bash ${D}${base_bindir}
- fi
-}
-
-do_install_ptest () {
- make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
- cp ${B}/Makefile ${D}${PTEST_PATH}
- sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
-}
-
-pkg_postinst_${PN} () {
- touch $D${sysconfdir}/shells
- grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
- grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
-}
diff --git a/recipes-extended/bash/bash_4.2.bb b/recipes-extended/bash/bash_4.2.bb
deleted file mode 100644
index df196a7..0000000
--- a/recipes-extended/bash/bash_4.2.bb
+++ /dev/null
@@ -1,173 +0,0 @@
-require bash.inc
-
-# GPLv2+ (< 4.0), GPLv3+ (>= 4.0)
-LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-
-PR = "r7"
-
-SRC_URI = "${GNU_MIRROR}/bash/${BPN}-${PV}.tar.gz;name=tarball \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-001;apply=yes;striplevel=0;name=patch001 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-002;apply=yes;striplevel=0;name=patch002 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-003;apply=yes;striplevel=0;name=patch003 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-004;apply=yes;striplevel=0;name=patch004 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-005;apply=yes;striplevel=0;name=patch005 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-006;apply=yes;striplevel=0;name=patch006 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-007;apply=yes;striplevel=0;name=patch007 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-008;apply=yes;striplevel=0;name=patch008 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-009;apply=yes;striplevel=0;name=patch009 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-010;apply=yes;striplevel=0;name=patch010 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-011;apply=yes;striplevel=0;name=patch011 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-012;apply=yes;striplevel=0;name=patch012 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-013;apply=yes;striplevel=0;name=patch013 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-014;apply=yes;striplevel=0;name=patch014 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-015;apply=yes;striplevel=0;name=patch015 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-016;apply=yes;striplevel=0;name=patch016 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-017;apply=yes;striplevel=0;name=patch017 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-018;apply=yes;striplevel=0;name=patch018 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-019;apply=yes;striplevel=0;name=patch019 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-020;apply=yes;striplevel=0;name=patch020 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-021;apply=yes;striplevel=0;name=patch021 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-022;apply=yes;striplevel=0;name=patch022 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-023;apply=yes;striplevel=0;name=patch023 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-024;apply=yes;striplevel=0;name=patch024 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-025;apply=yes;striplevel=0;name=patch025 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-026;apply=yes;striplevel=0;name=patch026 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-027;apply=yes;striplevel=0;name=patch027 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-028;apply=yes;striplevel=0;name=patch028 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-029;apply=yes;striplevel=0;name=patch029 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-030;apply=yes;striplevel=0;name=patch030 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-031;apply=yes;striplevel=0;name=patch031 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-032;apply=yes;striplevel=0;name=patch032 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-033;apply=yes;striplevel=0;name=patch033 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-034;apply=yes;striplevel=0;name=patch034 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-035;apply=yes;striplevel=0;name=patch035 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-036;apply=yes;striplevel=0;name=patch036 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-037;apply=yes;striplevel=0;name=patch037 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-038;apply=yes;striplevel=0;name=patch038 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-039;apply=yes;striplevel=0;name=patch039 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-040;apply=yes;striplevel=0;name=patch040 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-041;apply=yes;striplevel=0;name=patch041 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-042;apply=yes;striplevel=0;name=patch042 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-043;apply=yes;striplevel=0;name=patch043 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-044;apply=yes;striplevel=0;name=patch044 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-045;apply=yes;striplevel=0;name=patch045 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-046;apply=yes;striplevel=0;name=patch046 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-047;apply=yes;striplevel=0;name=patch047 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-048;apply=yes;striplevel=0;name=patch048 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-049;apply=yes;striplevel=0;name=patch049 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-050;apply=yes;striplevel=0;name=patch050 \
- ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-051;apply=yes;striplevel=0;name=patch051 \
- file://execute_cmd.patch;striplevel=0 \
- file://mkbuiltins_have_stringize.patch \
- file://build-tests.patch \
- file://test-output.patch \
- file://run-ptest \
- "
-
-SRC_URI[tarball.md5sum] = "3fb927c7c33022f1c327f14a81c0d4b0"
-SRC_URI[tarball.sha256sum] = "a27a1179ec9c0830c65c6aa5d7dab60f7ce1a2a608618570f96bfa72e95ab3d8"
-SRC_URI[patch001.md5sum] = "1100bc1dda2cdc06ac44d7e5d17864a3"
-SRC_URI[patch001.sha256sum] = "8d6ca028576c4af23e660a2fbc2112221a11c8a785c0b37f033967e5cd12b47a"
-SRC_URI[patch002.md5sum] = "30e7948079921d3261efcc6a40722135"
-SRC_URI[patch002.sha256sum] = "febac927e199aceeba2004908d971d4afb49b521796c3f42d1166f9fbbfbcef9"
-SRC_URI[patch003.md5sum] = "9ea06decec43a198f3d7cf29acc602f8"
-SRC_URI[patch003.sha256sum] = "5a0a7c15018c87348ea87cb0beea14345faf878dbb0e25c17fa70677194cb4cd"
-SRC_URI[patch004.md5sum] = "fb48f6134d7b013135929476aa0c250c"
-SRC_URI[patch004.sha256sum] = "4e34b0f830d2583d56e14225a66937abc81f45bbafcd2eb49daf61c9462140c1"
-SRC_URI[patch005.md5sum] = "e70e45de33426b38153b390be0dbbcd4"
-SRC_URI[patch005.sha256sum] = "a81749e73004b81cfdf0fe075bec365dc1fef756ee5e3fd142821e317d1459a0"
-SRC_URI[patch006.md5sum] = "ce4e5c484993705b27daa151eca242c2"
-SRC_URI[patch006.sha256sum] = "c91148945a2ddafa792682d7c8668c59e7e645eae1334b15b0d5d9ad22634bd1"
-SRC_URI[patch007.md5sum] = "88d1f96db29461767602e2546803bda7"
-SRC_URI[patch007.sha256sum] = "405826acf443dd1084f236a15cb76d7f0ee2dbe5edff45c5fb836db571fb7e95"
-SRC_URI[patch008.md5sum] = "24c574bf6d6a581e300823d9c1276af6"
-SRC_URI[patch008.sha256sum] = "23080d11a60a78941210e2477f6bca066b45db03defa60da86fd765107ba2437"
-SRC_URI[patch009.md5sum] = "4c5835f2fbab36c4292bb334977e5b6d"
-SRC_URI[patch009.sha256sum] = "e7ed5440b4c19765786e90e4f1ded43195d38b3e4d1c4b39fcc23de9a74ccb20"
-SRC_URI[patch010.md5sum] = "0a51602b535ef661ee707be6c8bdb373"
-SRC_URI[patch010.sha256sum] = "acfc5482c25e6923116fcf4b4f7f6345b80f75ad7299749db4b736ad67aa43dc"
-SRC_URI[patch011.md5sum] = "58deacf3d57cbd75575444ff6a3b0806"
-SRC_URI[patch011.sha256sum] = "a491ae359a7ebbd7321aede561728289d71e1fc84777f402766a8afd4d261532"
-SRC_URI[patch012.md5sum] = "72d5059820015231483bb7415d09e9db"
-SRC_URI[patch012.sha256sum] = "354433f1d2da02f1b9652cd20a5b85bbfb5bc2aaf79c42461ebd929d89b9b7b8"
-SRC_URI[patch013.md5sum] = "608336ebe215984ef126e3c29d2d3409"
-SRC_URI[patch013.sha256sum] = "3412c5c6cbbce6c88592604aec054d8182ce64410038b5ecea69fc3968cf85ea"
-SRC_URI[patch014.md5sum] = "ed19da878e3f630834c62b9d9dcc6fce"
-SRC_URI[patch014.sha256sum] = "b5a678e609858532735f94faedb5fabce00dfd6577a4e9ec5eec85fe682c8b33"
-SRC_URI[patch015.md5sum] = "2d07daba0b8ca8f876d2aa052ff594b4"
-SRC_URI[patch015.sha256sum] = "2d876a8304bdf3d664e87e0a8d73bc4ccc100a9dd8c0d054e8649472d8748a98"
-SRC_URI[patch016.md5sum] = "53d246537e1fffd1aaa02ba5c056211c"
-SRC_URI[patch016.sha256sum] = "2895ccbcf7fc98da73a8fa3ba7440aaf2bfaef6c0af8bdd3a9c39403cf03e2a6"
-SRC_URI[patch017.md5sum] = "304fd129a58fee2d8a34f8b4704db0aa"
-SRC_URI[patch017.sha256sum] = "73552444498c761d6073dd67ccfe043b36ef24bb418c266d91d9750884daee7f"
-SRC_URI[patch018.md5sum] = "6921a0b4228fe89b6537a5c29f027c89"
-SRC_URI[patch018.sha256sum] = "e2a9457172370d454d31b84bbcba758ee6394316dbe755374553b52aadbb494d"
-SRC_URI[patch019.md5sum] = "1195d85447f3d048d2c9bcd075fa765c"
-SRC_URI[patch019.sha256sum] = "a8b7cd02207656976016d93cab48e073cb5da002ceb27b7a63fc5ea62007eb56"
-SRC_URI[patch020.md5sum] = "b09000bba08da6ac753124593850cdf7"
-SRC_URI[patch020.sha256sum] = "494773f0d0078cb35372d24caa523b00d8fdbbaed71e41dc14c9e47579da3c6f"
-SRC_URI[patch021.md5sum] = "09d3f96a16b881334cfaee0cf320b47e"
-SRC_URI[patch021.sha256sum] = "a887a97be226575ecf483be2c76655bd6d1edde1cdfe199c27bd2e6baf32badc"
-SRC_URI[patch022.md5sum] = "597bf71a2aac6feb510b7505cdd3d4f7"
-SRC_URI[patch022.sha256sum] = "9dcdf69df7f8cd2ba88d18c45a0d8f55fbe4f0e273411179db94dd6198b85c6b"
-SRC_URI[patch023.md5sum] = "3fab459b4e09daea529cacad025b13b3"
-SRC_URI[patch023.sha256sum] = "5dc11394f1a6c887373c081396efd4f4cc04492696722c57a4811c207965f0bf"
-SRC_URI[patch024.md5sum] = "4ad8d11e72afc6090e701073ff034cf4"
-SRC_URI[patch024.sha256sum] = "99c826bdd33bee281d0a9191550d62a24d0b256cd41c90afd10abd63a66b99e6"
-SRC_URI[patch025.md5sum] = "c7d2493e44490f01dd20bdc8feb0a6a7"
-SRC_URI[patch025.sha256sum] = "0db0646fd7a559d5702911192bdd387acbbc61cf3c29a34007c3ec840e275515"
-SRC_URI[patch026.md5sum] = "9f19c199dd8d1fa9254eebe738759272"
-SRC_URI[patch026.sha256sum] = "e7e90cfaabbce3b4b9c699994e9d9ea4a2f084fd9f37788a80b0b70b47d323d2"
-SRC_URI[patch027.md5sum] = "a6ed82daf034587aee2f2581ba5fe829"
-SRC_URI[patch027.sha256sum] = "0c1f6b7256fcc17f42c05f9bbb4138f8e8bb67e79c622c3485711b6f37f7ed42"
-SRC_URI[patch028.md5sum] = "da9265aa2527fd4a7481baa3e0550287"
-SRC_URI[patch028.sha256sum] = "204226de39ba81aaf3dd5a29cd59de052ec9f648538bb9e7f1c8150852b1ed7a"
-SRC_URI[patch029.md5sum] = "ec444d229e8899fbaaf6fc7de2d82ae6"
-SRC_URI[patch029.sha256sum] = "d0b08c0817bc5acdb28b466727622a8422ca4d61188313cf162443b7f338f581"
-SRC_URI[patch030.md5sum] = "b4bc1c4dc1b508ff9cdfc44f1a5039b5"
-SRC_URI[patch030.sha256sum] = "12594366591a136d8ccdcb8e218010f2ddab6be28a7f96d0ed32ca927e44afae"
-SRC_URI[patch031.md5sum] = "89390ff6a3c2ef7e09dd4b8b097a8e56"
-SRC_URI[patch031.sha256sum] = "55f38c4d34775fbb063510c4222b195d998dd86f88288b64a6103e3812f8d9f9"
-SRC_URI[patch032.md5sum] = "eee08003395c417f677d1a4bf8c548ee"
-SRC_URI[patch032.sha256sum] = "e3a8b563dbb1e5cb7ca85a53515da8b2941213973496d48c4cc5a11c604791ed"
-SRC_URI[patch033.md5sum] = "2fe070dd6d75d8ff16f269184a16e9c4"
-SRC_URI[patch033.sha256sum] = "f5d12790d69fdfb2f47ac86fa1ea1ecc088880141570273f38dfd3fa4a46434b"
-SRC_URI[patch034.md5sum] = "4e610506c1711bf3483b965800ac3d5d"
-SRC_URI[patch034.sha256sum] = "01c1f332101389cedf347c7736102966722a3b213900954e5d625bbc2f1e41b8"
-SRC_URI[patch035.md5sum] = "7cd9bfdf7cbfd45274d07620ee94c8d9"
-SRC_URI[patch035.sha256sum] = "cecde463b038b4849635ff0993d9b264fc92403e7ae0accb52c7877aeaed78df"
-SRC_URI[patch036.md5sum] = "9c3142956064d175a880bcb186e51ef9"
-SRC_URI[patch036.sha256sum] = "fe293a1bc92ac4d272ae9b9a0de3afef7c06145a2b52337a09cacccc5305aafa"
-SRC_URI[patch037.md5sum] = "c10692f447d4966c879f8fb8d7c8ebc9"
-SRC_URI[patch037.sha256sum] = "c7578cddd3bb2430689c740f58a03403800726dcd1268b28f91bf37f368e1674"
-SRC_URI[patch038.md5sum] = "9ef3c308cde413e95866c1266cfb4e98"
-SRC_URI[patch038.sha256sum] = "b8c9a81bdf206be58ba491dfad80373b3348af769e80aaf72f7611ddbbbe6d57"
-SRC_URI[patch039.md5sum] = "cd48f57a404498d4e5c73a3501c4b1a5"
-SRC_URI[patch039.sha256sum] = "f4f9300a60321a5088ae9e54052a64c4d3e876f9a3a17ca104d58fa38b9c1791"
-SRC_URI[patch040.md5sum] = "00a2371b6c05acbfce6bc850c6d982f8"
-SRC_URI[patch040.sha256sum] = "b265f9caf3c7321f95bc8e0b9e2c46bd86c226f00f05e823699aafb83c4aaa6c"
-SRC_URI[patch041.md5sum] = "7bc4942a66ca4024ee964db7ede07896"
-SRC_URI[patch041.sha256sum] = "05cc1951bd9f6624088dd6067486ff47f1825e333273d7df5f1b06b23baaf5eb"
-SRC_URI[patch042.md5sum] = "1cf7701017ebfc8e129de92c8f8b798c"
-SRC_URI[patch042.sha256sum] = "faaa5c1f456517b258b2a65eaa664dd6a01eeff73c8ca4447c3a6de371bbf304"
-SRC_URI[patch043.md5sum] = "9e61168fca692d8d1a733c389a63712e"
-SRC_URI[patch043.sha256sum] = "dc2683840f3e890a9c5f85338366ff6cd923285e558eb46aa818a03fa67c5c57"
-SRC_URI[patch044.md5sum] = "b4b11d64b45ea9ec50dcc74c6c3861f6"
-SRC_URI[patch044.sha256sum] = "10d32d6c9ccdedb1d826f46468631d475f9dcf983fac087766e16df7b99766e6"
-SRC_URI[patch045.md5sum] = "1661bcc83c4715f54368877452ff2247"
-SRC_URI[patch045.sha256sum] = "ddb7eff0f59d394a483b09feec3771d9026f81ba90afac32846a19b172b2986d"
-SRC_URI[patch046.md5sum] = "1b68157ac0f7140e1ceafbbad4a14fee"
-SRC_URI[patch046.sha256sum] = "95c1323b68c0ecc0ca09565ef2d5218625ced3957b702e04c8bcaad9e7b3816d"
-SRC_URI[patch047.md5sum] = "10fbe341bd6b5dd1e94c2384f24e98b4"
-SRC_URI[patch047.sha256sum] = "c1979201d0345011c419a1c82407cd2a00c60a0c75b7f07e145d17f3718daf7a"
-SRC_URI[patch048.md5sum] = "87c31c1ace423d3ce8d1e26ba13bc724"
-SRC_URI[patch048.sha256sum] = "751a5d2330b21ac9aba7323acbbc91c948285f30a4bb41f56796f9a36b983d24"
-SRC_URI[patch049.md5sum] = "07083eeb372bd8215050a8146acc1efd"
-SRC_URI[patch049.sha256sum] = "901cd74cdd9f3e9bb5cc907d563e3d4dcdf9d5f6a751e85b706a958f51bc510e"
-SRC_URI[patch050.md5sum] = "d7b28ed8e839463f4554d67afb4f15e9"
-SRC_URI[patch050.sha256sum] = "1a19b84455e83b46fcaa27759a5dd643dde2e11ceacd1e84e351970ea04d8ba6"
-SRC_URI[patch051.md5sum] = "7dfd10542744c75aa1fd9be7109573bb"
-SRC_URI[patch051.sha256sum] = "3e15347bc23a116b8ee898acec9d0ac744612ce9bbc0096fff47c4cf1149051c"
-
-BBCLASSEXTEND = "nativesdk"