summaryrefslogtreecommitdiff
path: root/recipes-extended/lighttpd/lighttpd_%.bbappend
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2017-02-13 14:34:48 -0600
committerJohn Klug <john.klug@multitech.com>2017-05-23 15:21:54 -0500
commit14bf87bc4cf2c389c624ffdb1a6d09c24e3ab9d0 (patch)
tree029329eb712b12647f786a1562ac33991d2647dc /recipes-extended/lighttpd/lighttpd_%.bbappend
parent6fbfbe0cb5df5546beda2b88a19a398ea0ebdbc8 (diff)
downloadmeta-mlinux-14bf87bc4cf2c389c624ffdb1a6d09c24e3ab9d0.tar.gz
meta-mlinux-14bf87bc4cf2c389c624ffdb1a6d09c24e3ab9d0.tar.bz2
meta-mlinux-14bf87bc4cf2c389c624ffdb1a6d09c24e3ab9d0.zip
Initial commit of Yocto 2.1 changes
Diffstat (limited to 'recipes-extended/lighttpd/lighttpd_%.bbappend')
-rw-r--r--recipes-extended/lighttpd/lighttpd_%.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-extended/lighttpd/lighttpd_%.bbappend b/recipes-extended/lighttpd/lighttpd_%.bbappend
new file mode 100644
index 0000000..473a113
--- /dev/null
+++ b/recipes-extended/lighttpd/lighttpd_%.bbappend
@@ -0,0 +1,21 @@
+PR .= ".mlinux1"
+
+# build with openssl support
+DEPENDS += " openssl "
+RDEPENDS_${PN} += " openssl logrotate "
+
+EXTRA_OECONF += "--with-openssl"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
+
+SRC_URI += "file://lighttpd.logrotate.conf \
+ file://lighttpd.default"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lighttpd.logrotate.conf ${D}${sysconfdir}/logrotate.d/lighttpd.conf
+ install -m 0644 ${WORKDIR}/lighttpd.default ${D}${sysconfdir}/default/lighttpd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf"