summaryrefslogtreecommitdiff
path: root/recipes-extended/bash/bash-4.2
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-11-11 18:48:27 -0600
committerJohn Klug <john.klug@multitech.com>2020-11-11 18:48:27 -0600
commitb00be59bbc49535097c450b6b8c5fc10c1efd6dd (patch)
tree25cf0e14f66c5fca1cfe41b31bf862d60a36cf12 /recipes-extended/bash/bash-4.2
parentdb088915be6dca3f09dedbcdaa7264d9271b1c74 (diff)
downloadmeta-mlinux-GitosisMultiarch.tar.gz
meta-mlinux-GitosisMultiarch.tar.bz2
meta-mlinux-GitosisMultiarch.zip
Merge multiarch project to: added missing index file 2020 June 11GitosisMultiarch
Diffstat (limited to 'recipes-extended/bash/bash-4.2')
-rw-r--r--recipes-extended/bash/bash-4.2/build-tests.patch48
-rw-r--r--recipes-extended/bash/bash-4.2/execute_cmd.patch17
-rw-r--r--recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch26
-rw-r--r--recipes-extended/bash/bash-4.2/run-ptest2
-rw-r--r--recipes-extended/bash/bash-4.2/test-output.patch25
5 files changed, 0 insertions, 118 deletions
diff --git a/recipes-extended/bash/bash-4.2/build-tests.patch b/recipes-extended/bash/bash-4.2/build-tests.patch
deleted file mode 100644
index 0360881..0000000
--- a/recipes-extended/bash/bash-4.2/build-tests.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Add 'ptest' target to Makefile, to run tests without checking dependencies.
-
-Signed-off-by: Anders Roxell <anders.roxell@enea.com>
-Upstream-Status: Pending
----
-diff -uNr a/Makefile.in b/Makefile.in
---- a/Makefile.in 2012-11-06 08:40:07.552403063 +0100
-+++ b/Makefile.in 2012-11-06 11:13:36.958297555 +0100
-@@ -827,20 +827,34 @@
- fi
-
- recho$(EXEEXT): $(SUPPORT_SRC)recho.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)recho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
- zecho$(EXEEXT): $(SUPPORT_SRC)zecho.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)zecho.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
- printenv$(EXEEXT): $(SUPPORT_SRC)printenv.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)printenv.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
- xcase$(EXEEXT): $(SUPPORT_SRC)xcase.c
-- @$(CC_FOR_BUILD) $(CCFLAGS_FOR_BUILD) -o $@ $(SUPPORT_SRC)xcase.c ${LIBS_FOR_BUILD}
-+ @$(CC) $(CCFLAGS) -o $@ $<
-
--test tests check: force $(Program) $(TESTS_SUPPORT)
-+test tests check:
-+ @$(MAKE) install-test
-+ @$(MAKE) runtest
-+
-+install-test: buildtest
-+ifeq ($(origin INSTALL_TEST_DIR), undefined)
- @-test -d tests || mkdir tests
- @cp $(TESTS_SUPPORT) tests
-+else
-+ @-test -d $(INSTALL_TEST_DIR) || mkdir -p $(INSTALL_TEST_DIR)
-+ @cp -r $(srcdir)/tests/* $(INSTALL_TEST_DIR)/
-+ @cp $(TESTS_SUPPORT) $(INSTALL_TEST_DIR)
-+endif
-+
-+buildtest: force $(Program) $(TESTS_SUPPORT)
-+
-+runtest:
- @( cd $(srcdir)/tests && \
- PATH=$(BUILD_DIR)/tests:$$PATH THIS_SH=$(THIS_SH) $(SHELL) ${TESTSCRIPT} )
-
diff --git a/recipes-extended/bash/bash-4.2/execute_cmd.patch b/recipes-extended/bash/bash-4.2/execute_cmd.patch
deleted file mode 100644
index 81f8f0a..0000000
--- a/recipes-extended/bash/bash-4.2/execute_cmd.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
---- execute_cmd.c.orig Fri Jun 3 13:34:42 2011
-+++ execute_cmd.c Fri Jun 3 13:36:41 2011
-@@ -2202,7 +2202,11 @@
- /* If the `lastpipe' option is set with shopt, and job control is not
- enabled, execute the last element of non-async pipelines in the
- current shell environment. */
-- if (lastpipe_opt && job_control == 0 && asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
-+ if (lastpipe_opt &&
-+#if defined(JOB_CONTROL)
-+ job_control == 0 &&
-+#endif
-+ asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
- {
- lstdin = move_to_high_fd (0, 0, 255);
- if (lstdin > 0)
diff --git a/recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch b/recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch
deleted file mode 100644
index a9391d6..0000000
--- a/recipes-extended/bash/bash-4.2/mkbuiltins_have_stringize.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-On hosts with FORTIFY_SOURCES, stringize support is required, as it's used by
-the macros to wrap functions (e.g. read and open in unistd.h). Those wrappers
-use the STRING() macro from unistd.h. A header in the bash sources overrides
-the unistd.h macro to 'x' when HAVE_STRINGIZE is not defined, causing the
-wrappers to generate calls to 'xread' and 'xopen', which do not exist,
-resulting in a failure to link.
-
-Assume we have stringize support when cross-compiling, which works around the
-issue.
-
-It may be best for upstream to either give up on supporting compilers without
-stringize support, or to not define STRING() at all when FORTIFY_SOURCES is
-defined, letting the unistd.h one be used, instead.
-
-Upstream-Status: Pending
-
---- bash-4.2.orig/builtins/mkbuiltins.c
-+++ bash-4.2/builtins/mkbuiltins.c
-@@ -28,6 +28,7 @@
- # define HAVE_STDLIB_H
-
- # define HAVE_RENAME
-+# define HAVE_STRINGIZE
- #endif /* CROSS_COMPILING */
-
- #if defined (HAVE_UNISTD_H)
diff --git a/recipes-extended/bash/bash-4.2/run-ptest b/recipes-extended/bash/bash-4.2/run-ptest
deleted file mode 100644
index 8dd3b99..0000000
--- a/recipes-extended/bash/bash-4.2/run-ptest
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-make -k THIS_SH=/bin/bash BUILD_DIR=. runtest
diff --git a/recipes-extended/bash/bash-4.2/test-output.patch b/recipes-extended/bash/bash-4.2/test-output.patch
deleted file mode 100644
index 2b09b7d..0000000
--- a/recipes-extended/bash/bash-4.2/test-output.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Add FAIL/PASS output to test output.
-
-Signed-off-by: Björn Stenberg <bjst@enea.com>
-Upstream-Status: Pending
----
-diff -uNr a/tests/run-all b/tests/run-all
---- a/tests/run-all 1999-10-08 17:07:46.000000000 +0200
-+++ b/tests/run-all 2012-10-27 21:04:18.663331887 +0200
-@@ -22,7 +22,15 @@
- case $x in
- $0|run-minimal|run-gprof) ;;
- *.orig|*~) ;;
-- *) echo $x ; sh $x ;;
-+ *) echo $x
-+ output=`sh $x`
-+ if [ -n "$output" ]; then
-+ echo "$output"
-+ echo "FAIL: $x"
-+ else
-+ echo "PASS: $x"
-+ fi
-+ ;;
- esac
- done
-