summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-08-12 10:31:49 -0500
committerJohn Klug <john.klug@multitech.com>2016-08-12 10:31:49 -0500
commitf623fafb27e9eefd52aa34bcfa1c3b8e18c6d72b (patch)
tree723be36b9a8053234962b6f59164eb9e38b7485d /recipes-devtools
parentb713559f0a085bae1b035d1311d9d53574823fdd (diff)
downloadmeta-mlinux-f623fafb27e9eefd52aa34bcfa1c3b8e18c6d72b.tar.gz
meta-mlinux-f623fafb27e9eefd52aa34bcfa1c3b8e18c6d72b.tar.bz2
meta-mlinux-f623fafb27e9eefd52aa34bcfa1c3b8e18c6d72b.zip
Add python-pyopenssl_0.14.bb from https://git.congatec.com/yocto
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-pyopenssl_0.14.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyopenssl_0.14.bb b/recipes-devtools/python/python-pyopenssl_0.14.bb
new file mode 100644
index 0000000..ea6452a
--- /dev/null
+++ b/recipes-devtools/python/python-pyopenssl_0.14.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Simple Python wrapper around the OpenSSL library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCNAME = "pyOpenSSL"
+
+DEPENDS = "openssl"
+
+SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
+SRC_URI[md5sum] = "8579ff3a1d858858acfba5f046a4ddf7"
+SRC_URI[sha256sum] = "a99db8e59c120138ad8a72eecedcc24b4510d2eed3ce48213b7e32f22cc4ee6e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
+
+RDEPENDS_${PN} = "python-threading"
+RDEPENDS_${PN}-tests = "${PN}"