summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
committerJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
commite243c30f04c18722dc65effe6d4f275a3f35de46 (patch)
tree807610ce8af0ead02681d6c3cc89d902ec941652 /recipes-devtools
downloadmeta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.gz
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.bz2
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.zip
initial commit of mLinux layer
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/mtd/mtd-utils-static_git.bb17
-rw-r--r--recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch60
-rw-r--r--recipes-devtools/nodejs/nodejs_0.8.27.bb56
3 files changed, 133 insertions, 0 deletions
diff --git a/recipes-devtools/mtd/mtd-utils-static_git.bb b/recipes-devtools/mtd/mtd-utils-static_git.bb
new file mode 100644
index 0000000..8f64be4
--- /dev/null
+++ b/recipes-devtools/mtd/mtd-utils-static_git.bb
@@ -0,0 +1,17 @@
+require recipes-devtools/mtd/mtd-utils_git.bb
+
+# search for files in original recipe location
+FILESPATH .= ":${@bb.utils.which(BBPATH, 'recipes-devtools/mtd/mtd-utils', direction=True)}"
+
+PR = "r0"
+
+PACKAGES = "${PN} ${PN}-dbg"
+
+# build static version of nandwrite for flash upgrading
+CFLAGS += "-static"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/nandwrite ${D}${bindir}/nandwrite.static
+}
+
diff --git a/recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch b/recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch
new file mode 100644
index 0000000..6268d69
--- /dev/null
+++ b/recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch
@@ -0,0 +1,60 @@
+From bf701e7cb3616631a354ed9ecbed6dd16f60c60d Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 30 Jan 2013 10:43:47 +0100
+Subject: [PATCH] gcc has a builtin define to denote hard abi when in use, e.g.
+ when using -mfloat-abi=hard it will define __ARM_PCS_VFP to 1 and therefore
+ we should check that to determine which calling convention is in use and not
+ __VFP_FP__ which merely indicates presence of VFP unit
+
+The fix has been provided by Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Forwarded
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ deps/v8/src/arm/assembler-arm.cc | 4 ++--
+ deps/v8/src/platform-linux.cc | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/deps/v8/src/arm/assembler-arm.cc b/deps/v8/src/arm/assembler-arm.cc
+index 1787d15..c64ef58 100644
+--- a/deps/v8/src/arm/assembler-arm.cc
++++ b/deps/v8/src/arm/assembler-arm.cc
+@@ -71,10 +71,10 @@ static unsigned CpuFeaturesImpliedByCompiler() {
+ // If the compiler is allowed to use VFP then we can use VFP too in our code
+ // generation even when generating snapshots. ARMv7 and hardware floating
+ // point support implies VFPv3, see ARM DDI 0406B, page A1-6.
+-#if defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__VFP_FP__) \
++#if defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__ARM_PCS_VFP) \
+ && !defined(__SOFTFP__)
+ answer |= 1u << VFP3 | 1u << ARMv7 | 1u << VFP2;
+-#endif // defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__VFP_FP__)
++#endif // defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__ARM_PCS_VFP)
+ // && !defined(__SOFTFP__)
+ #endif // _arm__
+
+diff --git a/deps/v8/src/platform-linux.cc b/deps/v8/src/platform-linux.cc
+index ed9eb79..10d1879 100644
+--- a/deps/v8/src/platform-linux.cc
++++ b/deps/v8/src/platform-linux.cc
+@@ -170,7 +170,7 @@ bool OS::ArmCpuHasFeature(CpuFeature feature) {
+ // calling this will return 1.0 and otherwise 0.0.
+ static void ArmUsingHardFloatHelper() {
+ asm("mov r0, #0":::"r0");
+-#if defined(__VFP_FP__) && !defined(__SOFTFP__)
++#if defined(__ARM_PCS_VFP) && !defined(__SOFTFP__)
+ // Load 0x3ff00000 into r1 using instructions available in both ARM
+ // and Thumb mode.
+ asm("mov r1, #3":::"r1");
+@@ -195,7 +195,7 @@ static void ArmUsingHardFloatHelper() {
+ #else
+ asm("vmov d0, r0, r1");
+ #endif // __thumb__
+-#endif // defined(__VFP_FP__) && !defined(__SOFTFP__)
++#endif // defined(__ARM_PCS_VFP) && !defined(__SOFTFP__)
+ asm("mov r1, #0":::"r1");
+ }
+
+--
+1.8.1
+
diff --git a/recipes-devtools/nodejs/nodejs_0.8.27.bb b/recipes-devtools/nodejs/nodejs_0.8.27.bb
new file mode 100644
index 0000000..7a2b1d7
--- /dev/null
+++ b/recipes-devtools/nodejs/nodejs_0.8.27.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
+HOMEPAGE = "http://nodejs.org"
+LICENSE = "MIT & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=95a589a3257ab7dfe37d8a8379e3c72d"
+
+DEPENDS = "openssl"
+
+# use newer npm version that supports caret (^) versions
+# https://github.com/npm/npm/issues/4849
+SRCREV_npm = "v1.4.23"
+
+SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
+ file://0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch \
+ git://github.com/npm/npm.git;destsuffix=npm;name=npm \
+"
+SRC_URI[md5sum] = "afb113584498d2248825650b94e590a9"
+SRC_URI[sha256sum] = "30608f9dcd9ad122f7e8e6212f95969979e3dc35309d0c422a56486334a9369e"
+
+S = "${WORKDIR}/node-v${PV}"
+
+# v8 errors out if you have set CCACHE
+CCACHE = ""
+
+ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)}"
+ARCHFLAGS ?= ""
+
+# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
+do_configure () {
+ export LD="${CXX}"
+
+ ./configure --prefix=${prefix} --without-snapshot ${ARCHFLAGS}
+}
+
+do_compile () {
+ export LD="${CXX}"
+ make BUILDTYPE=Release
+}
+
+do_install () {
+ # backup original bundled npm
+ if [ ! -d deps/npm.orig ]; then
+ mv deps/npm deps/npm.orig
+ else
+ rm -rf deps/npm
+ fi
+ # install updated npm from git repo
+ cp -r ${WORKDIR}/npm deps/npm
+
+ oe_runmake install DESTDIR=${D}
+}
+
+RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
+RDEPENDS_${PN}_class-native = ""
+
+FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules ${libdir}/dtrace"
+BBCLASSEXTEND = "native"