summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-06-11 17:01:35 -0500
committerJohn Klug <john.klug@multitech.com>2018-06-11 17:01:35 -0500
commit8037537bc59c59aa8164da2c08598f43718dadf8 (patch)
tree4389210a4f0a5a1d95d616e089028554f3e421ff /recipes-devtools
parent6809c6fb5c5e8e79d2c00a8fd618a759b86b9060 (diff)
downloadmeta-mlinux-8037537bc59c59aa8164da2c08598f43718dadf8.tar.gz
meta-mlinux-8037537bc59c59aa8164da2c08598f43718dadf8.tar.bz2
meta-mlinux-8037537bc59c59aa8164da2c08598f43718dadf8.zip
Fix up rfcomm daemon to log the name with the Bluetooth address
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-pybluez.inc21
-rw-r--r--recipes-devtools/python/python-pybluez_0.22.bb2
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pybluez.inc b/recipes-devtools/python/python-pybluez.inc
new file mode 100644
index 0000000..399fe57
--- /dev/null
+++ b/recipes-devtools/python/python-pybluez.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "Bluetooth Python extension module"
+HOMEPAGE = "http://karulis.github.io/pybluez/"
+SECTION = "devel/python"
+
+DEPENDS = "bluez5"
+
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
+
+inherit pypi
+
+SRC_URI = "https://pypi.python.org/packages/c1/98/3149481d508bee174335be6725880f00d297afebe75c15e917af8f6fe169/PyBluez-0.22.zip"
+SRC_URI[md5sum] = "49dab9d5a8f0b798c8125c7f649be3cd"
+SRC_URI[sha256sum] = "4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d"
+
+S = "${WORKDIR}/PyBluez-${PV}"
+
+RDEPENDS_${PN} += "\
+ bluez5 \
+ ${PYTHON_PN}-fcntl \
+"
diff --git a/recipes-devtools/python/python-pybluez_0.22.bb b/recipes-devtools/python/python-pybluez_0.22.bb
new file mode 100644
index 0000000..3158f4b
--- /dev/null
+++ b/recipes-devtools/python/python-pybluez_0.22.bb
@@ -0,0 +1,2 @@
+require python-pybluez.inc
+inherit setuptools