summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-01-22 17:22:38 -0600
committerJesse Gilles <jgilles@multitech.com>2015-01-22 17:22:38 -0600
commit5f6b9bdc1568a0c657ce4f13195e13911f9be955 (patch)
tree1bad247216fbd70a7285544c8e509aabc6c55405 /recipes-devtools
parent8946c51abbd3fb41b855213b3edc648b79a28469 (diff)
downloadmeta-mlinux-5f6b9bdc1568a0c657ce4f13195e13911f9be955.tar.gz
meta-mlinux-5f6b9bdc1568a0c657ce4f13195e13911f9be955.tar.bz2
meta-mlinux-5f6b9bdc1568a0c657ce4f13195e13911f9be955.zip
add node-red 0.9.1 recipe
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/node-red/node-red_0.9.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/node-red/node-red_0.9.1.bb b/recipes-devtools/node-red/node-red_0.9.1.bb
new file mode 100644
index 0000000..dbcc5d4
--- /dev/null
+++ b/recipes-devtools/node-red/node-red_0.9.1.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Node-RED"
+HOMEPAGE = "http://nodered.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+DEPENDS = "nodejs nodejs-native"
+PR = "r0"
+
+inherit npm
+
+# tag 0.9.1
+SRCREV = "da1321f1dea0545ed9782d7fa6a18b855bafd8d9"
+
+SRC_URI = "git://github.com/node-red/node-red.git \
+ "
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ # npm install dependencies
+ oe_runnpm install --production
+ # npm install more stuff
+ # nodemailer 0.7.1 is latest that can be used with node 0.8.x
+ oe_runnpm install serialport@1.4.2 nodemailer@0.7.1
+
+ # remove dupe deps
+ oe_runnpm dedupe
+
+ # install node-red
+ install -d ${D}/opt/node-red
+ cp -r * ${D}/opt/node-red/
+}
+
+FILES_${PN} += "/opt/node-red"