summaryrefslogtreecommitdiff
path: root/recipes-devtools/node-red/node-red_0.11.1.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-06-07 11:38:08 -0500
committerJohn Klug <john.klug@multitech.com>2017-06-07 11:38:08 -0500
commit6fc48b75d08f5b1fc0d4b8aaddd664bc52687abb (patch)
tree37708ba86aeef3dce060be904f2686ab3a3d2d76 /recipes-devtools/node-red/node-red_0.11.1.bb
parentcb560a2d27a63190c83ac3329d50066fa754b5c7 (diff)
downloadmeta-mlinux-6fc48b75d08f5b1fc0d4b8aaddd664bc52687abb.tar.gz
meta-mlinux-6fc48b75d08f5b1fc0d4b8aaddd664bc52687abb.tar.bz2
meta-mlinux-6fc48b75d08f5b1fc0d4b8aaddd664bc52687abb.zip
Build patched node-red serialport and remove x86_64 serialport package
Diffstat (limited to 'recipes-devtools/node-red/node-red_0.11.1.bb')
-rw-r--r--recipes-devtools/node-red/node-red_0.11.1.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes-devtools/node-red/node-red_0.11.1.bb b/recipes-devtools/node-red/node-red_0.11.1.bb
index 0eb3ab6..fc9809e 100644
--- a/recipes-devtools/node-red/node-red_0.11.1.bb
+++ b/recipes-devtools/node-red/node-red_0.11.1.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://nodered.org"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
DEPENDS = "nodejs nodejs-native"
+RDEPENDS_${PN} += "bash"
PR = "r0"
FILESEXTRAPATHS_prepend := ":${THISDIR}/files:"
SRC_URI += "file://errnopatch.txt"
@@ -17,11 +18,11 @@ do_install() {
# npm install locally
oe_runnpm install --prefix ./ node-red@0.11.1
- # Patch for 6.2 compiler and errno overload issue
- patch -N -p1 <errnopatch.txt
-
# npm install more stuff
- oe_runnpm install --prefix ./node_modules/node-red nodemailer serialport
+ oe_runnpm install --prefix./node_modules/node-red nodemailer
+ # Build patched serialport.
+ # Original is https://registry.npmjs.org/serialport/-/serialport-1.7.4.tgz
+ oe_runnpm install --prefix ./node_modules/node-red http://multitech.net/mlinux/sources/node-red-serialport-1.7.4-mt1.tgz
# modules needed for loragw
oe_runnpm install --prefix ./node_modules/node-red extend dissolve node-constants
@@ -38,6 +39,9 @@ do_install() {
rm ./node_modules/node-red/nodes/core/hardware/nrgpio
rm ./node_modules/node-red/nodes/core/hardware/nrgpio.py
+ # remove x86_64 serialport 0.0.5
+ rm -r ./node_modules/node-red/node_modules/node-red-node-serialport
+
# install node-red
install -d ${D}/opt/node-red
cp -r ./node_modules/node-red/* ${D}/opt/node-red/