summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2021-12-06 16:02:44 +0200
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2021-12-06 16:02:44 +0200
commit1049c2fd703c28fb688d3e75538534cc6e32445f (patch)
tree731a8301eb271fd509519e7663cdff1d4d20eab9 /recipes-core
parent3908aa3d25d583420d36976bc1a2f11f38b5410d (diff)
downloadmeta-mlinux-1049c2fd703c28fb688d3e75538534cc6e32445f.tar.gz
meta-mlinux-1049c2fd703c28fb688d3e75538534cc6e32445f.tar.bz2
meta-mlinux-1049c2fd703c28fb688d3e75538534cc6e32445f.zip
MTCAP3: Fix fstab after introducing reduntant partitions
Commit 3908aa3d25d583420d36976bc1a2f11f38b5410d removes the fstab manipulation. In mPower the configuration partition is selected during boot time from config.init, without modifying fstab, which in turn saves the flash erase cycles by not making nay changes on rootfs/overlay. This commit updates the fstab to permanently use the first configuration partition as /var/config. The second partition is not used in mLinux. This approach is similar to the one for mLinux on MTCDT3. If one needs a config partition switchover on mLinux - please implement it in a similar manner to mPower, wihout making changes on rootfs during boot.
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files/fstab-ubifs/fstab4
-rw-r--r--recipes-core/base-files/fstab-ubifs_1.0.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-core/base-files/fstab-ubifs/fstab b/recipes-core/base-files/fstab-ubifs/fstab
index 8cca798..4560bb3 100644
--- a/recipes-core/base-files/fstab-ubifs/fstab
+++ b/recipes-core/base-files/fstab-ubifs/fstab
@@ -6,5 +6,5 @@ tmpfs /run tmpfs mode=0755,nodev,nosuid,stri
tmpfs /var/volatile tmpfs defaults 0 0
configfs /sys/kernel/config configfs defaults 0 0
-ubi0:config /var/config ubifs defaults 0 0
-ubi0:oem /var/oem ubifs defaults,ro 0 0
+ubi0:config1 /var/config ubifs defaults 0 0
+ubi0:oem1 /var/oem ubifs defaults,ro 0 0
diff --git a/recipes-core/base-files/fstab-ubifs_1.0.bb b/recipes-core/base-files/fstab-ubifs_1.0.bb
index cd2102a..533293a 100644
--- a/recipes-core/base-files/fstab-ubifs_1.0.bb
+++ b/recipes-core/base-files/fstab-ubifs_1.0.bb
@@ -1,7 +1,7 @@
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
inherit allarch
-PR = "r1"
+PR = "r2"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
PROVIDES = "fstab"
DEPENDS = "base-files"