summaryrefslogtreecommitdiff
path: root/recipes-core/multitech
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-10-05 15:45:57 -0500
committerJohn Klug <john.klug@multitech.com>2020-10-05 15:45:57 -0500
commit8bfd4d3474d0a33f2493c7b1df3a9ed6aa770fb6 (patch)
treee839c70ca7d5570b5292ff70be42d98efc950022 /recipes-core/multitech
parentaebca2fbd7b95abfe6e364c8f84a605f66129ca4 (diff)
downloadmeta-mlinux-8bfd4d3474d0a33f2493c7b1df3a9ed6aa770fb6.tar.gz
meta-mlinux-8bfd4d3474d0a33f2493c7b1df3a9ed6aa770fb6.tar.bz2
meta-mlinux-8bfd4d3474d0a33f2493c7b1df3a9ed6aa770fb6.zip
Fix chat_wrapper so APN can be changed when roaming
Diffstat (limited to 'recipes-core/multitech')
-rwxr-xr-xrecipes-core/multitech/config/chat_wrapper2
-rw-r--r--recipes-core/multitech/config_2.3.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/multitech/config/chat_wrapper b/recipes-core/multitech/config/chat_wrapper
index b0bf9e5..c65dd81 100755
--- a/recipes-core/multitech/config/chat_wrapper
+++ b/recipes-core/multitech/config/chat_wrapper
@@ -312,7 +312,7 @@ fi
uptime=$(cat /proc/uptime)
[[ $uptime =~ ^([^\.]*) ]]
t0=${BASH_REMATCH[1]}
-while ! [[ $(/usr/bin/radio-query ${RADIOOPTION} --netreg) =~ ^REGISTERED$ ]] ; do
+while ! [[ $(/usr/bin/radio-query ${RADIOOPTION} --netreg) =~ ^(REGISTERED|ROAMING)$ ]] ; do
sleep 5
((WAITREG++))
uptime=$(cat /proc/uptime)
diff --git a/recipes-core/multitech/config_2.3.bb b/recipes-core/multitech/config_2.3.bb
index 8418207..41187e9 100644
--- a/recipes-core/multitech/config_2.3.bb
+++ b/recipes-core/multitech/config_2.3.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
RDEPENDS_${PN} += "bash"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PACKAGE_ARCH = "all"
-PR = "r10"
+PR = "r11"
PACKAGES =+ "${PN}-mths"
inherit update-rc.d
inherit allarch