summaryrefslogtreecommitdiff
path: root/recipes-core/images
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-10-16 15:36:49 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:21 +0300
commit978059a76730c55d25f860b1e426e491a922f41b (patch)
tree9aaf997c4533f8fe5b7e833796da025a02bdc8f3 /recipes-core/images
parent3abf20cd709b0ec18280f836dabb5d7e48589211 (diff)
downloadmeta-mlinux-978059a76730c55d25f860b1e426e491a922f41b.tar.gz
meta-mlinux-978059a76730c55d25f860b1e426e491a922f41b.tar.bz2
meta-mlinux-978059a76730c55d25f860b1e426e491a922f41b.zip
rorootfs cpio image for initramfs
Diffstat (limited to 'recipes-core/images')
-rw-r--r--recipes-core/images/core-image-rorootfs-overlay-initramfs.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
new file mode 100644
index 0000000..47946c5
--- /dev/null
+++ b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
@@ -0,0 +1,23 @@
+# Simple initramfs image. Mostly used for live images.
+# Derived from https://github.com/cmhe/meta-readonly-rootfs-overlay
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), mounts the root fs \
+read only and uses a file system overlay for written data."
+
+PACKAGE_INSTALL = "initramfs-readonly-rootfs-overlay ${VIRTUAL-RUNTIME_base-utils} udev base-passwd gptfdisk ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "${PN}"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"