summaryrefslogtreecommitdiff
path: root/recipes-core/annex-proto
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-10-26 15:40:35 -0500
committerBrandon Bayer <bbayer@multitech.com>2016-11-03 16:40:10 -0500
commit4d6aefceec69079f3069440f6a9d2f3ea30aee89 (patch)
tree46f0208a5287f2307fc8782ec9c3fee7cc4100d0 /recipes-core/annex-proto
parent5e1da7aeca498961c20147c356990752a4cb2d87 (diff)
downloadmeta-mlinux-4d6aefceec69079f3069440f6a9d2f3ea30aee89.tar.gz
meta-mlinux-4d6aefceec69079f3069440f6a9d2f3ea30aee89.tar.bz2
meta-mlinux-4d6aefceec69079f3069440f6a9d2f3ea30aee89.zip
feat: add annex-client
Diffstat (limited to 'recipes-core/annex-proto')
-rw-r--r--recipes-core/annex-proto/annex-proto.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/annex-proto/annex-proto.bb b/recipes-core/annex-proto/annex-proto.bb
new file mode 100644
index 0000000..cbb6fb2
--- /dev/null
+++ b/recipes-core/annex-proto/annex-proto.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Provides the Multi-Tech MDM client protobuffer definitions"
+SECTION = "remote-management"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PR = "r20"
+PROVIDES = "annex_proto"
+DEPENDS = "protobuf"
+SRCREV = "7ad3f17a59d3fe564da099518310d61ad1304913"
+
+SRC_URI = "git://git@${MTS_INTERNAL_GIT}/annex/proto.git;protocol=ssh;branch=master \
+"
+S = "${WORKDIR}/git"
+
+# don't use cli here
+do_compile() {
+ echo "directory: `pwd`"
+}
+
+do_install() {
+ install annex.proto ${STAGING_DIR_NATIVE}
+}
+
+
+