summaryrefslogtreecommitdiff
path: root/recipes-core/annex-client/annex-client-from-src.bb
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-10-26 15:40:35 -0500
committerBrandon Bayer <bbayer@multitech.com>2016-11-03 16:40:10 -0500
commit4d6aefceec69079f3069440f6a9d2f3ea30aee89 (patch)
tree46f0208a5287f2307fc8782ec9c3fee7cc4100d0 /recipes-core/annex-client/annex-client-from-src.bb
parent5e1da7aeca498961c20147c356990752a4cb2d87 (diff)
downloadmeta-mlinux-4d6aefceec69079f3069440f6a9d2f3ea30aee89.tar.gz
meta-mlinux-4d6aefceec69079f3069440f6a9d2f3ea30aee89.tar.bz2
meta-mlinux-4d6aefceec69079f3069440f6a9d2f3ea30aee89.zip
feat: add annex-client
Diffstat (limited to 'recipes-core/annex-client/annex-client-from-src.bb')
-rw-r--r--recipes-core/annex-client/annex-client-from-src.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-core/annex-client/annex-client-from-src.bb b/recipes-core/annex-client/annex-client-from-src.bb
new file mode 100644
index 0000000..ee7dee9
--- /dev/null
+++ b/recipes-core/annex-client/annex-client-from-src.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Provides the Multi-Tech MDM client"
+SECTION = "remote-management"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PROVIDES = "annex-client-from-src"
+DEPENDS = "jsoncpp curl protobuf cyrus-sasl protobuf-native annex-proto mts-io"
+
+PR = "r0"
+SRCREV = "a696a7660bf153fec126cf971442c60961c51782"
+
+SRC_URI = "git://git@${MTS_INTERNAL_GIT}/multitech/annex-client.git;protocol=ssh;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ echo "directory: `pwd`"
+ mkdir -p annex_pb
+ cp ${STAGING_DIR_NATIVE}/annex.proto annex_pb/
+ make all CFLAGS+="-DMLINUX_BUILD"
+}
+
+# IMPORTANT NOTE:
+# this recipe is only used for the annex-client Jenkin's job to build IPK.
+# annex-client.bb is used to install the binary in an image
+do_install() {
+ oe_runmake install DESTDIR=${D} SUBDIRS="src"
+}