summaryrefslogtreecommitdiff
path: root/recipes-connectivity/strongswan/strongswan_%.bbappend
diff options
context:
space:
mode:
authorMykola Salomatin <mykola.salomatin@globallogic.com>2023-01-26 19:30:38 +0200
committerMykola Salomatin <mykola.salomatin@globallogic.com>2023-01-26 19:30:38 +0200
commit8b2c5033c01df17ce1bed9489570a5e56e3be862 (patch)
tree8a7abda338d1c144e904cd54e6ab99322119969e /recipes-connectivity/strongswan/strongswan_%.bbappend
parente77d906d6f9d0da38ab5faff8b2a11a4383650de (diff)
parent755c00a4dfc34c95640e832ca8cafb71a7d356aa (diff)
downloadmeta-mlinux-8b2c5033c01df17ce1bed9489570a5e56e3be862.tar.gz
meta-mlinux-8b2c5033c01df17ce1bed9489570a5e56e3be862.tar.bz2
meta-mlinux-8b2c5033c01df17ce1bed9489570a5e56e3be862.zip
Merge branch '6' into mpower-dev-l6g1
Diffstat (limited to 'recipes-connectivity/strongswan/strongswan_%.bbappend')
-rw-r--r--recipes-connectivity/strongswan/strongswan_%.bbappend18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-connectivity/strongswan/strongswan_%.bbappend b/recipes-connectivity/strongswan/strongswan_%.bbappend
index c68b45e..3286caa 100644
--- a/recipes-connectivity/strongswan/strongswan_%.bbappend
+++ b/recipes-connectivity/strongswan/strongswan_%.bbappend
@@ -1,3 +1,19 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:${THISDIR}/files:"
+
+PR.=".mts2"
PACKAGECONFIG_remove = "sqlite3"
+
+PACKAGECONFIG_append = "stroke"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/ipsec.d/
+ ln -sf /var/run/ipsec/ipsec.conf ${D}${sysconfdir}/ipsec.conf
+ ln -sf /var/run/ipsec/ipsec.secrets ${D}${sysconfdir}/ipsec.secrets
+ rm -rf ${D}${sysconfdir}/ipsec.d/cacerts
+ ln -sf /var/run/ipsec/cacerts ${D}${sysconfdir}/ipsec.d/cacerts
+ rm -rf ${D}${sysconfdir}/ipsec.d/certs
+ ln -sf /var/run/ipsec/certs ${D}${sysconfdir}/ipsec.d/certs
+ rm -rf ${D}${sysconfdir}/ipsec.d/private
+ ln -sf /var/run/ipsec/private ${D}${sysconfdir}/ipsec.d/private
+}