summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2020-07-17 13:30:04 -0500
committerJason Reiss <jreiss@multitech.com>2020-07-17 13:30:04 -0500
commit6a2a940137eecfd7d480883f34d657086f5e1766 (patch)
tree4f64db702794e5309f6a7a81d4f30d7940c6d468 /recipes-connectivity/lora
parentad7558982f72d8a378bb18f8f1340aaf6cc482bd (diff)
downloadmeta-mlinux-6a2a940137eecfd7d480883f34d657086f5e1766.tar.gz
meta-mlinux-6a2a940137eecfd7d480883f34d657086f5e1766.tar.bz2
meta-mlinux-6a2a940137eecfd7d480883f34d657086f5e1766.zip
lora: update lns to 2.4.0
Diffstat (limited to 'recipes-connectivity/lora')
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server/lora-network-server.init6
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.4.0.bb (renamed from recipes-connectivity/lora/lora-network-server_2.3.9.bb)4
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-connectivity/lora/lora-network-server/lora-network-server.init b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
index 61af0f4..5e2f085 100755
--- a/recipes-connectivity/lora/lora-network-server/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
@@ -244,7 +244,7 @@ do_start() {
echo -n "Starting $NAME: "
# start network server
start-stop-daemon --start --background --make-pidfile \
- --pidfile $net_server_pidfile --startas /bin/bash -- -c "exec $angel $net_server \
+ --pidfile $net_server_pidfile --startas /bin/bash -- -c "exec $net_server \
-c $conf_file --lora-eui $lora_eui --lora-hw-1 $lora_hw --lora-prod-1 $lora_id $lora_2_args \
--lora-path $run_dir \
--noconsole 2>&1"
@@ -258,12 +258,12 @@ do_start() {
fi
/usr/sbin/start-stop-daemon --chdir $run_dir/1 --start --background --make-pidfile \
--pidfile $pkt_fwd_pidfile --startas /bin/bash \
- -- -c "exec $angel $pkt_fwd $pkt_fwd_options 2>&1"
+ -- -c "exec $pkt_fwd $pkt_fwd_options 2>&1"
if [ "$dual_cards_installed" == "true" ]; then
/usr/sbin/start-stop-daemon --chdir $run_dir/2 --start --background --make-pidfile \
--pidfile $pkt_fwd_2_pidfile --startas /bin/bash \
- -- -c "exec $angel $pkt_fwd_2 $pkt_fwd_options -l $pkt_fwd_2_log"
+ -- -c "exec $pkt_fwd_2 $pkt_fwd_options -l $pkt_fwd_2_log"
fi
fi
diff --git a/recipes-connectivity/lora/lora-network-server_2.3.9.bb b/recipes-connectivity/lora/lora-network-server_2.4.0.bb
index 7e63635..3b00dc9 100644
--- a/recipes-connectivity/lora/lora-network-server_2.3.9.bb
+++ b/recipes-connectivity/lora/lora-network-server_2.4.0.bb
@@ -13,8 +13,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
file://lora-network-server.default \
"
-SRC_URI[md5sum] = "88110a6a04b7c8ed02ee30102ba31e49"
-SRC_URI[sha256sum] = "a2f0305b0eb48d55a53b1dc358bde4618688ccf952c79f5d9d2e2d7474f28042"
+SRC_URI[md5sum] = "36c7bf1f457df064253c4491d4887b2a"
+SRC_URI[sha256sum] = "437694fef6ee384792250ecfca2a1a66854ab446f806c128cca7e5a6bc96bdf5"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"