summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server_2.2.40.bb
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2019-10-31 09:40:53 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:21 +0300
commitf55416a64e699ef486a823a815eed94fe491594c (patch)
treeb216c06f81e7b7af3dbf0a0f0bcc96e620d8f43f /recipes-connectivity/lora/lora-network-server_2.2.40.bb
parent14d66e58683d44ab7c5902d8765b3cdb8c5f5d5e (diff)
downloadmeta-mlinux-f55416a64e699ef486a823a815eed94fe491594c.tar.gz
meta-mlinux-f55416a64e699ef486a823a815eed94fe491594c.tar.bz2
meta-mlinux-f55416a64e699ef486a823a815eed94fe491594c.zip
lora: update LNS to 2.2.40
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server_2.2.40.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.2.40.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_2.2.40.bb b/recipes-connectivity/lora/lora-network-server_2.2.40.bb
new file mode 100644
index 0000000..ee19f13
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_2.2.40.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2b9a30a3082ddccd2c695a4dbeeab80d"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3 curl gnutls"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging"
+PR = "r0"
+CONFFILES_${PN} += "${sysconfdir}/default/lora-network-server ${sysconfdir}/init.d/lora-network-server"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ "
+
+SRC_URI[md5sum] = "43c3197dda420a1894647cd72ef05ecd"
+SRC_URI[sha256sum] = "90b22e941adf0753f739267584a5812e8dfd055b17bbfd602d08e2704c6857c7"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+NETWORK_SERVER_VERSION_mtbsp-at91 = "4"
+NETWORK_SERVER_VERSION_mtbsp-ti = "5"
+NS_ARCH_mtbsp-at91 = ""
+NS_ARCH_mtbsp-ti = "armv7ahf-"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server-${NS_ARCH}mlinux-${NETWORK_SERVER_VERSION} ${D}${LORA_DIR}/lora-network-server
+ install -m 0755 lora-v21-keygen ${D}${LORA_DIR}/lora-v21-keygen
+ install -m 0644 config/lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+ install -m 0644 config/lora-network-server.conf.full ${D}${LORA_DIR}/lora-network-server.conf.full
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+}
+
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"