summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-gateway_5.0.6.bb
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2021-09-08 08:56:52 -0500
committerJason Reiss <jreiss@multitech.com>2021-09-08 08:56:52 -0500
commit1f4bf2002c7492d4361f791d3e75604c259f1aef (patch)
treeccf697a8602340a168e0b631303be4b16e872b93 /recipes-connectivity/lora/lora-gateway_5.0.6.bb
parent472e9af4cb161e5731e87fbafed0ca842c524a67 (diff)
downloadmeta-mlinux-1f4bf2002c7492d4361f791d3e75604c259f1aef.tar.gz
meta-mlinux-1f4bf2002c7492d4361f791d3e75604c259f1aef.tar.bz2
meta-mlinux-1f4bf2002c7492d4361f791d3e75604c259f1aef.zip
lora: update LNS, PKF and GW versions
Diffstat (limited to 'recipes-connectivity/lora/lora-gateway_5.0.6.bb')
-rw-r--r--recipes-connectivity/lora/lora-gateway_5.0.6.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-gateway_5.0.6.bb b/recipes-connectivity/lora/lora-gateway_5.0.6.bb
new file mode 100644
index 0000000..f16cadf
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway_5.0.6.bb
@@ -0,0 +1,71 @@
+DESCRIPTION = "LoRa Gateway library"
+HOMEPAGE = "https://github.com/Lora-net/lora_gateway"
+PRIORITY = "optional"
+SECTION = "console/utils"
+# Semtech license is a modified BSD-style license
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
+DEPENDS = "gpsd"
+
+PR = "r23"
+SRCREV = "004c03449d498cfa495df4d7834b733f4697a10f"
+
+SRC_URI = "git://git@gitlab.multitech.net/lora_enterprise/lora_gateway_mtac_full.git;protocol=ssh;branch=master \
+ file://library_4.0.cfg \
+ file://ln-lora-spi-dev.sh \
+ "
+
+SRC_URI[md5sum] = "9e06a3733a9fea39a3d61f77b412badf"
+SRC_URI[sha256sum] = "28fbfe098013908794b32e51d1fed4427f20dd6c8adbbca78df2e1800f5c84dc"
+
+S = "${WORKDIR}/git"
+
+CFLAGS += "-Iinc -I. -idirafter ${STAGING_DIR_TARGET}/usr/include/gps"
+
+do_configure_append() {
+ # copy over custom library_4.0.cfg
+ cp ${WORKDIR}/library_4.0.cfg ${S}/libloragw/library.cfg
+}
+
+do_compile() {
+ oe_runmake LDFLAGS=${LDFLAGS}
+}
+
+do_install() {
+ install -d ${D}${includedir}/lora
+ install -d ${D}${libdir}/lora
+ install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora
+ install -m 0644 libloragw/library.cfg ${D}${libdir}/lora
+ install -m 0644 libloragw/inc/* ${D}${includedir}/lora
+ install -m 0644 libloragw/readme.md ${D}${libdir}/lora/lora-gw-readme.md
+
+ install -d ${D}/opt/lora/
+
+ install -d ${D}/opt/lora/gateway-utils
+ install -m 0755 libloragw/test_* ${D}/opt/lora/gateway-utils/
+ install -m 0755 util_pkt_logger/util_pkt_logger ${D}/opt/lora/gateway-utils/
+ install -m 0755 util_spectral_scan/util_spectral_scan ${D}/opt/lora/gateway-utils/
+ install -m 0755 util_spi_stress/util_spi_stress ${D}/opt/lora/gateway-utils/
+ install -m 0755 util_tx_test/util_tx_test ${D}/opt/lora/gateway-utils/
+ install -m 0755 util_tx_continuous/util_tx_continuous ${D}/opt/lora/gateway-utils/
+ install -m 0755 util_lbt_test/util_lbt_test ${D}/opt/lora/gateway-utils/
+}
+
+do_install_append_mtcdt() {
+ install -m 0755 ${WORKDIR}/ln-lora-spi-dev.sh ${D}/opt/lora/
+}
+
+
+PACKAGES += "${PN}-utils ${PN}-utils-dbg"
+
+FILES_${PN} = "${libdir}/lora/lora-gw-readme.md"
+FILES_${PN}-utils = "/opt/lora/gateway-utils/* /opt/lora/ln-lora-spi-dev.sh"
+FILES_${PN}-utils-dbg = "/opt/lora/gateway-utils/.debug /opt/lora/ln-lora-spi-dev.sh"
+FILES_${PN}-dev = "${includedir}/lora ${libdir}/lora/library.cfg"
+FILES_${PN}-staticdev = "${libdir}/lora/libloragw.a"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}
+