summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-gateway_5.0.12.bb
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2022-05-17 10:48:02 -0500
committerJason Reiss <jreiss@multitech.com>2022-05-17 10:48:02 -0500
commitb2214bae4b5bb177642eeb9f4a27f8b9bcf9c36f (patch)
tree20c8231a93c4e2faff1660ef80676336a0848c80 /recipes-connectivity/lora/lora-gateway_5.0.12.bb
parent159dd9c4756d3f2f4492533b093b3788d17ae3f3 (diff)
downloadmeta-mlinux-b2214bae4b5bb177642eeb9f4a27f8b9bcf9c36f.tar.gz
meta-mlinux-b2214bae4b5bb177642eeb9f4a27f8b9bcf9c36f.tar.bz2
meta-mlinux-b2214bae4b5bb177642eeb9f4a27f8b9bcf9c36f.zip
lora: update PKF and gateway recipes
Diffstat (limited to 'recipes-connectivity/lora/lora-gateway_5.0.12.bb')
-rw-r--r--recipes-connectivity/lora/lora-gateway_5.0.12.bb68
1 files changed, 0 insertions, 68 deletions
diff --git a/recipes-connectivity/lora/lora-gateway_5.0.12.bb b/recipes-connectivity/lora/lora-gateway_5.0.12.bb
deleted file mode 100644
index 90f3f51..0000000
--- a/recipes-connectivity/lora/lora-gateway_5.0.12.bb
+++ /dev/null
@@ -1,68 +0,0 @@
-DESCRIPTION = "LoRa Gateway library"
-HOMEPAGE = "https://github.com/Lora-net/lora_gateway"
-PRIORITY = "optional"
-SECTION = "console/utils"
-# Semtech license is a modified BSD-style license
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
-DEPENDS = "gpsd"
-RDEPENDS_${PN} = "libgps"
-
-PR = "r34"
-SRCREV = "${PV}"
-
-SRC_URI = "git://git.multitech.net/lora_gateway_mtac_full;branch=master;protocol=git \
- file://library_4.0.cfg \
- file://ln-lora-spi-dev.sh \
- "
-
-
-S = "${WORKDIR}/git"
-
-CFLAGS += "-Iinc -I. -idirafter ${STAGING_DIR_TARGET}/usr/include/gps"
-
-do_configure_append() {
- # copy over custom library_4.0.cfg
- cp ${WORKDIR}/library_4.0.cfg ${S}/libloragw/library.cfg
-}
-
-do_compile() {
- oe_runmake
-}
-
-do_install() {
- install -d ${D}${includedir}/lora
- install -d ${D}${libdir}/lora
- install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora
- install -m 0644 libloragw/library.cfg ${D}${libdir}/lora
- install -m 0644 libloragw/inc/* ${D}${includedir}/lora
- install -m 0644 libloragw/readme.md ${D}${libdir}/lora/lora-gw-readme.md
-
- install -d ${D}/opt/lora/
-
- install -d ${D}/opt/lora/gateway-utils
- install -m 0755 libloragw/test_* ${D}/opt/lora/gateway-utils/
- install -m 0755 util_pkt_logger/util_pkt_logger ${D}/opt/lora/gateway-utils/
- install -m 0755 util_spectral_scan/util_spectral_scan ${D}/opt/lora/gateway-utils/
- install -m 0755 util_spi_stress/util_spi_stress ${D}/opt/lora/gateway-utils/
- install -m 0755 util_tx_test/util_tx_test ${D}/opt/lora/gateway-utils/
- install -m 0755 util_tx_continuous/util_tx_continuous ${D}/opt/lora/gateway-utils/
- install -m 0755 util_lbt_test/util_lbt_test ${D}/opt/lora/gateway-utils/
-}
-
-do_install_append_mtcdt() {
- install -m 0755 ${WORKDIR}/ln-lora-spi-dev.sh ${D}/opt/lora/
-}
-
-PACKAGES += "${PN}-utils ${PN}-utils-dbg"
-
-FILES_${PN} = "${libdir}/lora/lora-gw-readme.md"
-FILES_${PN}-utils = "/opt/lora/gateway-utils/* /opt/lora/ln-lora-spi-dev.sh"
-FILES_${PN}-utils-dbg = "/opt/lora/gateway-utils/.debug /opt/lora/ln-lora-spi-dev.sh"
-FILES_${PN}-dev = "${includedir}/lora ${libdir}/lora/library.cfg"
-FILES_${PN}-staticdev = "${libdir}/lora/libloragw.a"
-
-# disable this on purpose for dev purposes
-do_rm_work() {
- echo "skipping"
-}