summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-gateway-sx1303_2.0.31.bb
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2022-12-07 10:27:07 -0600
committerHarsh Sharma <harsh.sharma@multitech.com>2022-12-07 10:27:07 -0600
commitdda1600e29d727cfc7737fc3271dbce6453867e3 (patch)
treee88b38dceb3294415895ba0ebaf3d94f9fe4a4de /recipes-connectivity/lora/lora-gateway-sx1303_2.0.31.bb
parent1b094c0c04abe9e305c6bed846c4d520732d5ca3 (diff)
downloadmeta-mlinux-dda1600e29d727cfc7737fc3271dbce6453867e3.tar.gz
meta-mlinux-dda1600e29d727cfc7737fc3271dbce6453867e3.tar.bz2
meta-mlinux-dda1600e29d727cfc7737fc3271dbce6453867e3.zip
Updated lora tags
Diffstat (limited to 'recipes-connectivity/lora/lora-gateway-sx1303_2.0.31.bb')
-rw-r--r--recipes-connectivity/lora/lora-gateway-sx1303_2.0.31.bb88
1 files changed, 0 insertions, 88 deletions
diff --git a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.31.bb b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.31.bb
deleted file mode 100644
index 68a6322..0000000
--- a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.31.bb
+++ /dev/null
@@ -1,88 +0,0 @@
-DESCRIPTION = "LoRa Packet Forwarder"
-HOMEPAGE = "https://github.com/MultiTechSystems/sx1302_hal"
-PRIORITY = "optional"
-SECTION = "console/utils"
-# Semtech license is a modified BSD-style license
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=d2119120bd616e725f4580070bd9ee19"
-DEPENDS = "logrotate gpsd"
-RDEPENDS_${PN} += "bash"
-
-PR = "r9"
-
-#SRCREV = "06531662f3ef73a0e9878ed5313451d8a6cafbc5"
-SRCREV = "V${PV}"
-
-SRC_URI = "git://github.com/MultiTechSystems/sx1302_hal.git;protocol=https;branch=master \
- file://reset_lgw.sh \
- file://global_conf.json.MTAC_003_0_0.EU868 \
- file://global_conf.json.MTAC_003_0_0.US915 \
- file://global_conf.json.MTCAP3.EU868 \
- file://global_conf.json.MTCAP3.US915 \
-"
-
-SRC_URI[sha256sum] = "dbfebdee1292e891d32bca52a9ef78b350557383d4d86c96c198e182249aa30f"
-
-
-S = "${WORKDIR}/git"
-B = "${S}"
-
-LORA_DIR = "/opt/lora"
-
-
-CFLAGS += "-DNODEBUG -I${S}/packet_forwarder/inc -I${S}/libloragw/inc -I${S}/libtools/inc -I${S}/inc -I. -idirafter ${STAGING_DIR_TARGET}/usr/include/gps -std=gnu11"
-
-do_compile() {
- oe_runmake packet_forwarder LDFLAGS=${LDFLAGS}
- oe_runmake util_boot LDFLAGS=${LDFLAGS}
- oe_runmake util_chip_id FLAGS=${LDFLAGS}
- oe_runmake util_net_downlink LDFLAGS=${LDFLAGS}
- oe_runmake util_spectral_scan LDFLAGS=${LDFLAGS}
-}
-
-do_install() {
- install -d ${D}${LORA_DIR}
- install -d ${D}${libdir}/lora
- install -d ${D}${libdir}/lora/lgw-sx1303/lgw
- install -d ${D}${includedir}/lora/lgw-sx1303/lgw
-
- install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora/lgw-sx1303/lgw/
- install -m 0644 libloragw/library.cfg ${D}${libdir}/lora/lgw-sx1303/lgw/
- install -m 0644 libloragw/inc/* ${D}${includedir}/lora/lgw-sx1303/lgw/
-
- install -d ${D}${LORA_DIR}/forwarder-utils-sx1303
- install -d ${D}${LORA_DIR}/gateway-utils-sx1303
- install -m 755 ${WORKDIR}/reset_lgw.sh ${D}${LORA_DIR}/
- install -m 755 packet_forwarder/lora_pkt_fwd ${D}${LORA_DIR}/lora_pkt_fwd_sx1303
- install -m 755 libloragw/test_loragw* ${D}${LORA_DIR}/gateway-utils-sx1303/
- install -m 755 util_boot/boot ${D}${LORA_DIR}/forwarder-utils-sx1303/util_boot
- install -m 755 util_chip_id/chip_id ${D}${LORA_DIR}/forwarder-utils-sx1303/util_chip_id
- install -m 755 util_net_downlink/net_downlink ${D}${LORA_DIR}/forwarder-utils-sx1303/util_net_downlink
- install -m 755 util_spectral_scan/spectral_scan ${D}${LORA_DIR}/forwarder-utils-sx1303/
-}
-
-do_install_append_mtcdt() {
- install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
- install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
-}
-
-do_install_append_mtcap() {
-}
-
-do_install_append_mtcap3() {
- install -m 755 ${WORKDIR}/global_conf.json.MTCAP3.EU868 ${D}${LORA_DIR}/
- install -m 755 ${WORKDIR}/global_conf.json.MTCAP3.US915 ${D}${LORA_DIR}/
-}
-
-do_install_append_mtcpmhs() {
- install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
- install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
-}
-
-
-FILES_${PN} += "${LORA_DIR}"
-
-# disable this on purpose for dev purposes
-do_rm_work() {
- echo "skipping"
-}