summaryrefslogtreecommitdiff
path: root/recipes-connectivity/bluez/python3-pygattlib.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-04-29 17:04:44 -0500
committerJohn Klug <john.klug@multitech.com>2022-04-29 17:04:44 -0500
commit0ab21e40fa70c6ffc0d3057d4b87b4365d004c89 (patch)
tree0011279c8a0ef56a4475da82a87db8fbce531bfa /recipes-connectivity/bluez/python3-pygattlib.bb
parent205d9f31d962931bd33f03f78790fd60b8428b13 (diff)
downloadmeta-mlinux-0ab21e40fa70c6ffc0d3057d4b87b4365d004c89.tar.gz
meta-mlinux-0ab21e40fa70c6ffc0d3057d4b87b4365d004c89.tar.bz2
meta-mlinux-0ab21e40fa70c6ffc0d3057d4b87b4365d004c89.zip
python3-pygattlib is not yet ready
Diffstat (limited to 'recipes-connectivity/bluez/python3-pygattlib.bb')
-rw-r--r--recipes-connectivity/bluez/python3-pygattlib.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/recipes-connectivity/bluez/python3-pygattlib.bb b/recipes-connectivity/bluez/python3-pygattlib.bb
deleted file mode 100644
index 0a5aaee..0000000
--- a/recipes-connectivity/bluez/python3-pygattlib.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-DESCRIPTION = "Python BLE GATT Library"
-HOMEPAGE = "https://bitbucket.org/OscarAcena/pygattlib"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-DEPENDS = "boost bluez5 glib-2.0"
-
-inherit setuptools3
-
-PR = "r3"
-SRCREV = "f319522a2e719a9a05220b42ac16eb360be3fe1c"
-SRC_URI = "git://git@gitlab.multitech.net/aep/pygattlib.git;protocol=ssh;branch=master \
- file://0001-Fixed-build-with-Python3.8-and-Boost-1.72.patch \
-"
-
-SRC_URI[md5sum] = "014bf03c4812f74b6c9e86e1e895bb82"
-SRC_URI[sha256sum] = "f759070d59597db1f8d10991497f133eddb9d7f990d15571031d93a397a772e2"
-
-S = "${WORKDIR}/git"
-
-inherit autotools-brokensep pkgconfig
-
-# necessary to let the call for python3-config succeed
-export BUILD_SYS
-export HOST_SYS
-export STAGING_INCDIR
-export STAGING_LIBDIR
-
-do_compile() {
- oe_runmake
-}
-
-#TODO
-# QA Issue: File /usr/lib/python3.8/lib-dynload/gattlib.so in package pygattlib doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]
-do_install() {
- install -d ${D}/${libdir}/python3.8/lib-dynload
- install -m 0755 ${WORKDIR}/git/src/gattlib.so ${D}/${libdir}/python3.8/lib-dynload/gattlib.so
-}