summaryrefslogtreecommitdiff
path: root/contrib
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
committerJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
commite243c30f04c18722dc65effe6d4f275a3f35de46 (patch)
tree807610ce8af0ead02681d6c3cc89d902ec941652 /contrib
downloadmeta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.gz
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.bz2
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.zip
initial commit of mLinux layer
Diffstat (limited to 'contrib')
-rw-r--r--contrib/env-oe.sh16
-rw-r--r--contrib/local.conf51
-rw-r--r--contrib/user-layer.conf10
3 files changed, 77 insertions, 0 deletions
diff --git a/contrib/env-oe.sh b/contrib/env-oe.sh
new file mode 100644
index 0000000..53a3297
--- /dev/null
+++ b/contrib/env-oe.sh
@@ -0,0 +1,16 @@
+#!/usr/bin/env bash
+
+export OETREE=$(pwd)
+
+OECORE="${OETREE}/layers/openembedded-core"
+
+if [[ ! "${PATH}" =~ ${OETREE}/bitbake/bin ]]; then
+ export PATH="${OECORE}/scripts:${OETREE}/bitbake/bin:${PATH}"
+fi
+
+# define if you wish to create soft links to the image in the tftpboot dir
+#export TFTPBOOT_DIR=/tftpboot
+
+export BUILDDIR="${OETREE}"
+export BBPATH="${OETREE}:${OECORE}/meta"
+export BB_ENV_EXTRAWHITE="MACHINE DISTRO OETREE TFTPBOOT_DIR TCLIBC TCMODE GIT_PROXY_COMMAND http_proxy ftp_proxy https_proxy all_proxy ALL_PROXY no_proxy SSH_AGENT_PID SSH_AUTH_SOCK BB_SRCREV_POLICY SDKMACHINE BB_NUMBER_THREADS"
diff --git a/contrib/local.conf b/contrib/local.conf
new file mode 100644
index 0000000..66a1312
--- /dev/null
+++ b/contrib/local.conf
@@ -0,0 +1,51 @@
+# CONF_VERSION is increased each time build/conf/ changes incompatibly
+CONF_VERSION = "1"
+
+# Use MultiTech mLinux distribution
+DISTRO = "mlinux"
+MACHINE ?= "mtcdt"
+
+# Where to store downloaded sources
+DL_DIR = "${TOPDIR}/downloads"
+
+# Where to save shared state
+SSTATE_DIR = "${TOPDIR}/build/sstate-cache"
+# bitbake cache location
+PERSISTENT_DIR = "${TOPDIR}/build/cache"
+# build output
+TMPDIR = "${TOPDIR}/build/tmp"
+
+# Which files do we want to parse:
+BBFILES ?= "${TOPDIR}/layers/openembedded-core/meta/recipes-*/*/*.bb"
+
+# Go through the Firewall
+#HTTP_PROXY = "http://:/"
+
+# Uncomment this to remove unpacked source and intermediate work
+# after successfully building a package.
+# Saves a LOT of disk space, but leaving work around is useful for debugging.
+INHERIT += "rm_work"
+
+# skip parsing of masked files
+BBMASK = ""
+
+# Make use of SMP:
+# PARALLEL_MAKE specifies how many concurrent compiler threads are spawned per bitbake process
+# BB_NUMBER_THREADS specifies how many concurrent bitbake tasks will be run
+PARALLEL_MAKE = "-j4"
+BB_NUMBER_THREADS = "4"
+
+# Don't generate the mirror tarball for SCM repos, the snapshot is enough
+BB_GENERATE_MIRROR_TARBALLS = "0"
+
+# Disable build time patch resolution. This would lauch a devshell
+# and wait for manual intervention. We disable it.
+PATCHRESOLVE = "noop"
+
+# enable local PR server
+PRSERV_HOST = "localhost:0"
+
+# enable buildhistory for images
+INHERIT += "buildhistory"
+BUILDHISTORY_COMMIT = "0"
+BUILDHISTORY_FEATURES = "image"
diff --git a/contrib/user-layer.conf b/contrib/user-layer.conf
new file mode 100644
index 0000000..609f95b
--- /dev/null
+++ b/contrib/user-layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "user"
+BBFILE_PATTERN_user = "^${LAYERDIR}/"
+BBFILE_PRIORITY_user = "99"