summaryrefslogtreecommitdiff
path: root/contrib
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-07-19 11:34:14 -0500
committerJohn Klug <john.klug@multitech.com>2021-07-19 11:34:14 -0500
commit0142be7731c3c5eba56c3b67c04235c519d7fd72 (patch)
treee20ab5a8231bc46810bd0c9cba44fcc05cf8ec21 /contrib
parent69f9e9ff2edf0ebc4bbbf76125967646ee137d6c (diff)
downloadmeta-mlinux-0142be7731c3c5eba56c3b67c04235c519d7fd72.tar.gz
meta-mlinux-0142be7731c3c5eba56c3b67c04235c519d7fd72.tar.bz2
meta-mlinux-0142be7731c3c5eba56c3b67c04235c519d7fd72.zip
Kernel version changes, and path changes for multiarch builds
Diffstat (limited to 'contrib')
-rw-r--r--contrib/local.conf26
1 files changed, 22 insertions, 4 deletions
diff --git a/contrib/local.conf b/contrib/local.conf
index be0beb5..b699649 100644
--- a/contrib/local.conf
+++ b/contrib/local.conf
@@ -11,11 +11,11 @@ MACHINE ?= "mtcdt"
DL_DIR = "${TOPDIR}/downloads"
# Where to save shared state
-SSTATE_DIR = "${TOPDIR}/sstate-cache"
+SSTATE_DIR = "${TOPDIR}/build/sstate-cache"
# bitbake cache location
-PERSISTENT_DIR = "${TOPDIR}/cache"
+PERSISTENT_DIR = "${TOPDIR}/build/cache"
# build output
-TMPDIR = "${TOPDIR}/tmp"
+TMPDIR = "${TOPDIR}/build/tmp"
# Which files do we want to parse:
BBFILES ?= "${TOPDIR}/layers/openembedded-core/meta/recipes-*/*/*.bb"
@@ -67,5 +67,23 @@ IMAGE_FSTYPES =+ "jffs2 tar.gz"
# IMAGE_INSTALL += "openjdk-7-vm-zero"
PACKAGECONFIG_append_pn-boost = " python"
-HOSTTOOLS += "xz cmake"
OVERRIDES .= ":${MTBSP}"
+
+# This is populated in the respective kernel recipe
+MLINUX_KERNEL_VERSION = "${@oe.utils.read_file('${STAGING_KERNEL_BUILDDIR}/kernel-abiversion')}"
+MLINUX_KERNEL_EXTRA_VERSION = "${@oe.utils.read_file('${STAGING_KERNEL_BUILDDIR}/mlinux_pr')}"
+
+# Make builds reproducible
+BUILD_REPRODUCIBLE_BINARIES = "1"
+export PYTHONHASHSEED = "0"
+export PERL_HASH_SEED = "0"
+export TZ = 'UTC'
+export SOURCE_DATE_EPOCH ??= "1520598896"
+REPRODUCIBLE_TIMESTAMP_ROOTFS ??= "1520598896"
+
+# Add host utilities needed for Redpine driver unpack to the whitelist
+HOSTTOOLS += "xz cmake"
+
+# Enable CVE check for all images
+INHERIT += "${@'cve-check' if d.getVar('MTS_CHECK_CVES') == '1' else ''}"
+CVE_CHECK_REPORT_PATCHED = "0"