summaryrefslogtreecommitdiff
path: root/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/jsoncpp/jsoncpp_0.5.0.bb')
-rw-r--r--recipes-support/jsoncpp/jsoncpp_0.5.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp_0.5.0.bb b/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
new file mode 100644
index 0000000..18f1c86
--- /dev/null
+++ b/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Json C++ Library"
+HOMEPAGE = "http://jsoncpp.sourceforge.net/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+DEPENDS = ""
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"
+
+SRC_URI = " \
+ http://sw.multitech.prv/openembedded/sources/jsoncpp-src-0.5.0.tar.gz \
+ file://jsoncpp-0.5.0-p1.patch \
+ file://Makefile \
+"
+
+PR = "r2"
+
+# For tarball packages (as opposed to git / svn which include the commit in the URI)
+SRC_URI[md5sum] = "24482b67c1cb17aac1ed1814288a3a8f"
+SRC_URI[sha256sum] = "22b14ecd0de8cdad2b6b6839f6d0804d3b84e91f42861ebd843832a26a927433"
+
+S = "${WORKDIR}/jsoncpp-src-${PV}"
+
+do_compile() {
+ cp ../Makefile .
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+