summaryrefslogtreecommitdiff
path: root/recipes-ruby/ruby-serialport/ruby-serialport_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ruby/ruby-serialport/ruby-serialport_1.1.0.bb')
-rw-r--r--recipes-ruby/ruby-serialport/ruby-serialport_1.1.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-ruby/ruby-serialport/ruby-serialport_1.1.0.bb b/recipes-ruby/ruby-serialport/ruby-serialport_1.1.0.bb
new file mode 100644
index 0000000..a020f90
--- /dev/null
+++ b/recipes-ruby/ruby-serialport/ruby-serialport_1.1.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "A Ruby library that provides a class for using RS-232 serial ports"
+HOMEPAGE = "https://github.com/hparra/ruby-serialport"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+SECTION = "console/utils"
+PRIORITY = "optional"
+
+DEPENDS = "ruby"
+
+PR = "r2"
+
+# tag v1.1.0
+SRCREV = "709e385f6d20aaadc7f3252af59250336d27e607"
+
+SRC_URI = "git://github.com/hparra/ruby-serialport.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -Iext/native -I${STAGING_INCDIR}/ruby-1.9.1 -I${STAGING_INCDIR}/ruby-1.9.1/arm-linux-eabi -c ext/native/*.c
+ ${CC} ${CFLAGS} ${LDFLAGS} --shared -o ext/native/serialport.so serialport.o posix_serialport_impl.o
+}
+
+do_install() {
+ install -d ${D}${libdir}/ruby/serialport
+ install lib/serialport.rb ${D}${libdir}/ruby/serialport.rb
+ install ext/native/serialport.so -t ${D}${libdir}/ruby
+}
+
+FILES_${PN} = "${libdir}/ruby/serialport*"
+FILES_${PN}-dbg += "${libdir}/ruby/.debug"