summaryrefslogtreecommitdiff
path: root/recipes-extended/uvccapture/files/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/uvccapture/files/makefile.patch')
-rw-r--r--recipes-extended/uvccapture/files/makefile.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-extended/uvccapture/files/makefile.patch b/recipes-extended/uvccapture/files/makefile.patch
new file mode 100644
index 0000000..4733154
--- /dev/null
+++ b/recipes-extended/uvccapture/files/makefile.patch
@@ -0,0 +1,29 @@
+Index: uvccapture-0.5/Makefile
+===================================================================
+--- uvccapture-0.5.orig/Makefile 2011-08-18 14:02:17.757628553 -0500
++++ uvccapture-0.5/Makefile 2011-08-18 14:10:09.627899608 -0500
+@@ -1,8 +1,8 @@
+-CC=gcc
+-CPP=g++
++#CC=gcc
++#CPP=g++
+ APP_BINARY=uvccapture
+-VERSION = 0.4
+-PREFIX=/usr/local/bin
++VERSION = 0.5
++PREFIX=/usr/bin
+
+ WARNINGS = -Wall
+
+@@ -20,8 +20,9 @@
+ rm -f *.a *.o $(APP_BINARY) core *~ log errlog
+
+ install:
+- install $(APP_BINARY) $(PREFIX)
++ install -d $(DESTDIR)$(PREFIX)
++ install -m755 $(APP_BINARY) $(DESTDIR)$(PREFIX)
+
+ # Applications:
+ uvccapture: $(OBJECTS)
+- $(CC) $(OBJECTS) $(XPM_LIB) $(MATH_LIB) -ljpeg -o $(APP_BINARY)
++ $(CC) $(OBJECTS) $(XPM_LIB) $(MATH_LIB) -ljpeg $(LDFLAGS) -o $(APP_BINARY)