summaryrefslogtreecommitdiff
path: root/recipes-extended/autossh/autossh_1.4c.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/autossh/autossh_1.4c.bb')
-rw-r--r--recipes-extended/autossh/autossh_1.4c.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-extended/autossh/autossh_1.4c.bb b/recipes-extended/autossh/autossh_1.4c.bb
new file mode 100644
index 0000000..b40b53f
--- /dev/null
+++ b/recipes-extended/autossh/autossh_1.4c.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Keeps ssh tunnels alive"
+HOMEPAGE = "http://www.harding.motd.ca/autossh"
+LICENSE = "custom-freely-distributable"
+LIC_FILES_CHKSUM = "file://autossh.c;start_line=10;end_line=22;md5=60abb4e02db9c8a062426f574d2fccae"
+SECTION = "console/utils"
+PRIORITY = "optional"
+
+PR = "r1"
+
+SRC_URI = "http://www.harding.motd.ca/autossh/autossh-1.4c.tgz"
+SRC_URI[md5sum] = "26520eea934f296be0783dabe7fcfd28"
+SRC_URI[sha256sum] = "6fcaba6a409a46bdf832086736bb8f09d245ebce11027f41d39588a95dc7fd1d"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 755 ${S}/autossh ${D}/${bindir}/autossh
+}