summaryrefslogtreecommitdiff
path: root/recipes-core/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/images')
-rw-r--r--recipes-core/images/mlinux-base-image.bb57
-rw-r--r--recipes-core/images/mlinux-factory-image.bb61
-rw-r--r--recipes-core/images/mlinux-minimal-image.bb40
-rw-r--r--recipes-core/images/mlinux-mono-image.bb3
4 files changed, 161 insertions, 0 deletions
diff --git a/recipes-core/images/mlinux-base-image.bb b/recipes-core/images/mlinux-base-image.bb
new file mode 100644
index 0000000..939b309
--- /dev/null
+++ b/recipes-core/images/mlinux-base-image.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "mLinux base image"
+LICENSE = "MIT"
+
+require mlinux-minimal-image.bb
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf \
+ mii-diag \
+ tcpdump \
+ "
+
+WIFI_FEATURES = " \
+ libnl \
+ wpa-supplicant \
+ wireless-tools \
+ iw \
+ hostap-daemon hostap-utils \
+ "
+
+BLUETOOTH_FEATURES = "bluez4"
+
+# Add all timezones available
+# ntpdate will sync time every 30 min by default via cron
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+# u-boot-linux-utils: U-Boot environment access from Linux
+# ocg-scripts: sample scripts for setting up OCG for various tasks
+# reset-handler: default reset button handler
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ ocg-scripts \
+ reset-handler \
+ "
+
+MISC_FEATURES = "minicom lrzsz nano"
+
+# Extra stuff to install
+IMAGE_INSTALL += " \
+ ${WIFI_FEATURES} \
+ ${BLUETOOTH_FEATURES} \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${MISC_FEATURES} \
+ "
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
new file mode 100644
index 0000000..a0d1ef4
--- /dev/null
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -0,0 +1,61 @@
+require mlinux-base-image.bb
+
+LIGHTTPD = "lighttpd \
+ lighttpd-module-cgi lighttpd-module-indexfile \
+ lighttpd-module-redirect lighttpd-module-auth \
+ lighttpd-module-access lighttpd-module-accesslog \
+ lighttpd-module-rewrite lighttpd-module-proxy lighttpd-module-fastcgi \
+ lighttpd-module-scgi lighttpd-module-alias \
+ lighttpd-module-dirlisting lighttpd-module-staticfile \
+ "
+
+# Lighttpd web server
+IMAGE_INSTALL += "${LIGHTTPD}"
+
+IMAGE_INSTALL += "sqlite3"
+
+IMAGE_INSTALL += "autossh"
+
+# Perl support
+IMAGE_INSTALL += "perl"
+IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
+# not in meta-oe or oe-core...
+#IMAGE_INSTALL += "libdevice-serialport-perl"
+#IMAGE_INSTALL += "libexpect-perl"
+
+# Python support
+IMAGE_INSTALL += "python"
+IMAGE_INSTALL += "python-pyserial"
+IMAGE_INSTALL += "python-simplejson"
+IMAGE_INSTALL += "python-unixadmin"
+IMAGE_INSTALL += "python-textutils"
+IMAGE_INSTALL += "python-html"
+IMAGE_INSTALL += "python-sqlite3"
+
+# Ruby support
+IMAGE_INSTALL += "ruby"
+IMAGE_INSTALL += "ruby-sqlite3"
+IMAGE_INSTALL += "ruby-serialport"
+
+# OpenJDK Java runtime
+IMAGE_INSTALL += "openjdk-7-jre"
+# OpenJDK with JamVM VM (Multi-Tech default)
+IMAGE_INSTALL += "openjdk-7-vm-jamvm"
+# OpenJDK with CACAO VM (run with 'java -cacao')
+IMAGE_INSTALL += "openjdk-7-vm-cacao"
+# OpenJDK Zero VM (run with 'java -zero')
+IMAGE_INSTALL += "openjdk-7-vm-zero"
+
+# PHP support
+IMAGE_INSTALL += "php php-cli php-cgi"
+
+# Node.js support
+IMAGE_INSTALL += "nodejs"
+
+# Multi-Tech SMS Utility (see http://git.multitech.net)
+IMAGE_INSTALL += "sms-utils"
+# Multi-Tech GPS Utility
+IMAGE_INSTALL += "venus-gps"
+
+IMAGE_INSTALL += "uvccapture"
+
diff --git a/recipes-core/images/mlinux-minimal-image.bb b/recipes-core/images/mlinux-minimal-image.bb
new file mode 100644
index 0000000..522ee2a
--- /dev/null
+++ b/recipes-core/images/mlinux-minimal-image.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "mLinux minimal image"
+LICENSE = "MIT"
+
+inherit core-image
+inherit mlinux-image
+
+IMAGE_LINGUAS = ""
+IMAGE_FEATURES += "ssh-server-openssh package-management"
+
+CORE_FEATURES = "packagegroup-core-boot packagegroup-distro-base \
+ packagegroup-base-ext2 \
+ packagegroup-base-usbhost packagegroup-base-usbgadget \
+ udev-extraconf usb-gadget-mode \
+ sysfsutils module-init-tools kernel-modules \
+ bash procps mtd-utils mtd-utils-jffs2 \
+ openssh-sftp-server \
+ util-linux-mount util-linux-umount \
+ ${CORE_IMAGE_EXTRA_INSTALL} \
+ "
+
+NETWORKING_FEATURES = "ppp curl iproute2 \
+ iptables iputils \
+ "
+
+# mts-io: IO Controller for Multi-Tech hardware.
+# (LEDs, temp sensor, serial lines, and more)
+#
+# config: Handles default config files stored in /var/config.
+# /var/config is mounted on a separate flash partition so that config
+# files survive flashing of rootfs. See recipe for details.
+MULTITECH_FEATURES = "mts-io config mts-id-eeprom"
+
+UPGRADE_FEATURES = "upgrade-reboot mtd-utils-static"
+
+IMAGE_INSTALL = "${CORE_FEATURES} \
+ ${NETWORKING_FEATURES} \
+ ${UPGRADE_FEATURES} \
+ ${MULTITECH_FEATURES} \
+ "
+
diff --git a/recipes-core/images/mlinux-mono-image.bb b/recipes-core/images/mlinux-mono-image.bb
new file mode 100644
index 0000000..f15d7d2
--- /dev/null
+++ b/recipes-core/images/mlinux-mono-image.bb
@@ -0,0 +1,3 @@
+require mlinux-base-image.bb
+
+IMAGE_INSTALL += "mono mono-helloworld"