summaryrefslogtreecommitdiff
path: root/recipes-core/images/mlinux-factory-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/images/mlinux-factory-image.bb')
-rw-r--r--recipes-core/images/mlinux-factory-image.bb38
1 files changed, 34 insertions, 4 deletions
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index eb3c92d..6adf7e2 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -47,9 +47,9 @@ IMAGE_INSTALL_append = " perl-module-io perl-module-fcntl"
#IMAGE_INSTALL_append = " libexpect-perl"
# Python support
-IMAGE_INSTALL_append = " python"
-# Python modules
-IMAGE_INSTALL_append = " python-argparse \
+# Python 2 is obsolete.
+PYTHON_2_FEATURES = " python \
+python-argparse \
python-compression \
python-dateutil \
python-html \
@@ -64,7 +64,36 @@ python-syslog \
python-textutils \
python-unixadmin \
python-xml \
+python-dbus \
"
+PYTHON_3_FEATURES = " \
+ python3-core \
+ python3-logging \
+ python3-io \
+ python3-audio \
+ python3-compression \
+ python3-crypt \
+ python3-datetime \
+ python3-email \
+ python3-image \
+ python3-json \
+ python3-pyjwt \
+ python3-netclient \
+ python3-netserver \
+ python3-paho-mqtt \
+ python3-pycurl \
+ python3-pyserial \
+ python3-requests \
+ python3-shell \
+ python3-six \
+ python3-threading \
+ python3-twisted-core \
+ python3-urllib3 \
+ python3-dbus \
+ "
+
+IMAGE_INSTALL_append = "${PYTHON_3_FEATURES}"
+PYTHON_DEFAULT = "python-is-python3"
# OpenJDK Java runtime
# IMAGE_INSTALL_append = " openjdk-8"
@@ -89,8 +118,9 @@ IMAGE_INSTALL_append = " pps-tools"
IMAGE_INSTALL_append = " dnsmasq bluez5-pand bluez5-rfcomm"
# When ntp is to use the GPS, gpspipe is required
-IMAGE_INSTALL_append = " gpsd gpsd-conf gpsd-gpsctl libgps ntp ntp-utils gpspipe gps-utils"
+IMAGE_INSTALL_append = " gpsd gpsd-conf gpsd-gpsctl libgps ntp ntp-utils gpspipe gps-utils python3-pygps-pyc"
IMAGE_INSTALL_append = " uxfp qfirehose uvccapture"
IMAGE_INSTALL_append = " ppp-radioresetwait radio-reset-background"
+IMAGE_INSTALL_append = " ${PYTHON_DEFAULT}"