summaryrefslogtreecommitdiff
path: root/recipes-connectivity/openssh/openssh_6.5p1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssh/openssh_6.5p1.bbappend')
-rw-r--r--recipes-connectivity/openssh/openssh_6.5p1.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-connectivity/openssh/openssh_6.5p1.bbappend b/recipes-connectivity/openssh/openssh_6.5p1.bbappend
new file mode 100644
index 0000000..87891c8
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh_6.5p1.bbappend
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://ssh.default"
+
+KEYFILES = "ssh_host_dsa_key \
+ssh_host_dsa_key.pub \
+ssh_host_ecdsa_key \
+ssh_host_ecdsa_key.pub \
+ssh_host_rsa_key \
+ssh_host_rsa_key.pub \
+ssh_host_ed25519_key \
+ssh_host_ed25519_key.pub \
+"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/default
+ install -m 644 ${WORKDIR}/ssh.default ${D}${sysconfdir}/default/ssh
+ for f in ${KEYFILES}; do
+ ln -sf /var/config/ssh/$f ${D}${sysconfdir}/ssh/$f
+ done
+}