summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server-mtcap_2.0.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server-mtcap_2.0.14.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap_2.0.14.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/recipes-connectivity/lora/lora-network-server-mtcap_2.0.14.bb b/recipes-connectivity/lora/lora-network-server-mtcap_2.0.14.bb
deleted file mode 100644
index 9a6eda7..0000000
--- a/recipes-connectivity/lora/lora-network-server-mtcap_2.0.14.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-# THIS RECIPE FOR PICOCELL USES PATCHED LORA NETWORK SERVER THAT SUPPORTS
-# MTCAP HARDWARE AND V2 PACKET FORWARDER PROTOCOL
-DESCRIPTION = "MultiTech LoRa Network Server"
-PRIORITY = "optional"
-SECTION = "console/utils"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
-DEPENDS = "jsoncpp libmts mosquitto sqlite3 curl gnutls"
-RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash"
-PR = "r3"
-
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
- file://lora-network-server.conf \
- file://lora-network-server.init \
- file://lora-network-server.default \
- file://lora-network-server.logrotate.conf \
- file://local_conf.json \
- "
-
-SRC_URI[md5sum] = "17894d4d40374bf68052bcce38d1310c"
-SRC_URI[sha256sum] = "4baae18fdaef48278a004abfb16b5e0a20d9990c252d0bb9d8a592ffca9ff6d7"
-
-# binaries are already stripped, so suppress warning
-INSANE_SKIP_${PN} = "already-stripped"
-
-S = "${WORKDIR}"
-
-LORA_DIR = "/opt/lora"
-
-do_compile() {
-}
-
-do_install() {
- install -d ${D}${LORA_DIR}
- install -m 0755 lora-network-server ${D}${LORA_DIR}/
- install -m 0644 ${WORKDIR}/lora-network-server.conf ${D}${LORA_DIR}/
- install -m 0755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
- install -d ${D}${sysconfdir}/logrotate.d
- install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
-}
-
-CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
-FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"