summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@xenialxerusdm1.dc.multitech.prv>2019-09-16 09:20:41 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:21 +0300
commitec0ab233197d6a4e9dadefcd2c8fa5c2b9ceb2e2 (patch)
tree6392389588d4c8d894c8260850a4bc9ea809ee93 /recipes-core
parent4eba07b5b205d13134670b1c0983b44c1127e6f0 (diff)
downloadmeta-mlinux-atmel-ec0ab233197d6a4e9dadefcd2c8fa5c2b9ceb2e2.tar.gz
meta-mlinux-atmel-ec0ab233197d6a4e9dadefcd2c8fa5c2b9ceb2e2.tar.bz2
meta-mlinux-atmel-ec0ab233197d6a4e9dadefcd2c8fa5c2b9ceb2e2.zip
Updates to add docker
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/busybox/busybox_%.bbappend7
-rw-r--r--recipes-core/busybox/files/disable-ipc-for-docker.cfg2
2 files changed, 9 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend
index 31b58fa..ca0d56b 100644
--- a/recipes-core/busybox/busybox_%.bbappend
+++ b/recipes-core/busybox/busybox_%.bbappend
@@ -4,6 +4,13 @@ FILESEXTRAPATHS_prepend := ":${THISDIR}/files:"
RDEPENDS_${PN} += "bash"
DEPENDS += "libtirpc"
+#
+# MD: temporally disable IPCS/IPCRM (needed for ntpd/gpsd according to John)
+# because those are also provided by util-linux which is in RDEPENDS for docker
+#
+SRC_URI += "file://disable-ipc-for-docker.cfg \
+"
+
SRC_URI += "file://udhcpd.conf.example \
file://ifplugd.action \
file://ifplugd.default \
diff --git a/recipes-core/busybox/files/disable-ipc-for-docker.cfg b/recipes-core/busybox/files/disable-ipc-for-docker.cfg
new file mode 100644
index 0000000..c2a9405
--- /dev/null
+++ b/recipes-core/busybox/files/disable-ipc-for-docker.cfg
@@ -0,0 +1,2 @@
+# CONFIG_IPCS is not set
+# CONFIG_IPCRM is not set