summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-11-10 12:58:37 -0600
committerJason Reiss <jreiss@multitech.com>2016-11-10 12:58:37 -0600
commite093123ceafca8eb6d8d041e0ad09f67d1202c73 (patch)
tree009fbbbb4c6ece6b88f5006d78a8d2ab85a835f4 /recipes-core
parent75fd65e9f52aeea9ab27b4af85c1fa8b093e5be3 (diff)
parent38ded95350a89cae973df774242e3c35e98784d8 (diff)
downloadmeta-mlinux-atmel-e093123ceafca8eb6d8d041e0ad09f67d1202c73.tar.gz
meta-mlinux-atmel-e093123ceafca8eb6d8d041e0ad09f67d1202c73.tar.bz2
meta-mlinux-atmel-e093123ceafca8eb6d8d041e0ad09f67d1202c73.zip
merge: Conduit_0.1 changes into master
lora: update lora-network-server to 1.0.16
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/annex-client/annex-client-from-src.bb27
-rw-r--r--recipes-core/annex-client/annex-client.bb29
-rw-r--r--recipes-core/annex-client/annex-client/annex-client.init43
-rw-r--r--recipes-core/annex-proto/annex-proto.bb24
-rw-r--r--recipes-core/base-files/base-files/mtcap/fstab (renamed from recipes-core/base-files/base-files/mtp/fstab)0
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend2
-rw-r--r--recipes-core/images/mlinux-base-image.bb1
-rw-r--r--recipes-core/images/mlinux-mtcap-debug-image.bb13
-rw-r--r--recipes-core/images/mlinux-mtcap-image.bb (renamed from recipes-core/images/mlinux-picocell-image.bb)4
-rw-r--r--recipes-core/images/mlinux-picocell-debug-image.bb10
-rw-r--r--recipes-core/udev/udev-182/mtcap/mtcap.rules (renamed from recipes-core/udev/udev-182/mtp/mtp.rules)0
11 files changed, 141 insertions, 12 deletions
diff --git a/recipes-core/annex-client/annex-client-from-src.bb b/recipes-core/annex-client/annex-client-from-src.bb
new file mode 100644
index 0000000..ee7dee9
--- /dev/null
+++ b/recipes-core/annex-client/annex-client-from-src.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Provides the Multi-Tech MDM client"
+SECTION = "remote-management"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PROVIDES = "annex-client-from-src"
+DEPENDS = "jsoncpp curl protobuf cyrus-sasl protobuf-native annex-proto mts-io"
+
+PR = "r0"
+SRCREV = "a696a7660bf153fec126cf971442c60961c51782"
+
+SRC_URI = "git://git@${MTS_INTERNAL_GIT}/multitech/annex-client.git;protocol=ssh;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ echo "directory: `pwd`"
+ mkdir -p annex_pb
+ cp ${STAGING_DIR_NATIVE}/annex.proto annex_pb/
+ make all CFLAGS+="-DMLINUX_BUILD"
+}
+
+# IMPORTANT NOTE:
+# this recipe is only used for the annex-client Jenkin's job to build IPK.
+# annex-client.bb is used to install the binary in an image
+do_install() {
+ oe_runmake install DESTDIR=${D} SUBDIRS="src"
+}
diff --git a/recipes-core/annex-client/annex-client.bb b/recipes-core/annex-client/annex-client.bb
new file mode 100644
index 0000000..1a0544a
--- /dev/null
+++ b/recipes-core/annex-client/annex-client.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Provides the Multi-Tech MDM client"
+SECTION = "remote-management"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PROVIDES = "annex-client"
+
+# NOTE: annex-client binary is built with Jenkin's job using annex-client-from-src.bb
+# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+PR = "r0"
+SRC_URI = "http://multitech.net/downloads/annex-client-from-src_${PV}-${PR}.0_${TUNE_PKGARCH}.ipk \
+ file://annex-client.init \
+"
+
+SRC_URI[md5sum] = "b17462ba3883df6a06b226b37a523eba"
+SRC_URI[sha256sum] = "be903e7e27ad34832cb8045ef805f4e226aa6e254a3c995c5e61a0a9197a95b0"
+
+#inherit update-rc.d
+#
+#INITSCRIPT_NAME = "annex-client"
+#INITSCRIPT_PARAMS = "defaults 95 1"
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 755 sbin/annexcd ${D}${sbindir}
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/annex-client.init ${D}${sysconfdir}/init.d/annex-client
+}
diff --git a/recipes-core/annex-client/annex-client/annex-client.init b/recipes-core/annex-client/annex-client/annex-client.init
new file mode 100644
index 0000000..4a5dc4b
--- /dev/null
+++ b/recipes-core/annex-client/annex-client/annex-client.init
@@ -0,0 +1,43 @@
+#!/bin/bash
+
+MONITOR="/sbin/monitor-annexcd"
+CLIENT="annexcd"
+
+start() {
+ if [[ $(pidof -x $MONITOR) ]]; then
+ echo "RM client is already running"
+ else
+ echo "Starting RM client"
+ $MONITOR &
+ fi
+}
+
+stop() {
+ MONITOR_PID=$(pidof -x $MONITOR)
+ CLIENT_PID=$(pidof $CLIENT)
+ if [[ $MONITOR_PID ]]; then
+ echo "Stopping RM client"
+ kill $MONITOR_PID $CLIENT_PID
+ else
+ echo "RM client is not running"
+ fi
+}
+
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart)
+ stop
+ start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/annex-client {start|stop|restart}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-core/annex-proto/annex-proto.bb b/recipes-core/annex-proto/annex-proto.bb
new file mode 100644
index 0000000..cbb6fb2
--- /dev/null
+++ b/recipes-core/annex-proto/annex-proto.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Provides the Multi-Tech MDM client protobuffer definitions"
+SECTION = "remote-management"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PR = "r20"
+PROVIDES = "annex_proto"
+DEPENDS = "protobuf"
+SRCREV = "7ad3f17a59d3fe564da099518310d61ad1304913"
+
+SRC_URI = "git://git@${MTS_INTERNAL_GIT}/annex/proto.git;protocol=ssh;branch=master \
+"
+S = "${WORKDIR}/git"
+
+# don't use cli here
+do_compile() {
+ echo "directory: `pwd`"
+}
+
+do_install() {
+ install annex.proto ${STAGING_DIR_NATIVE}
+}
+
+
+
diff --git a/recipes-core/base-files/base-files/mtp/fstab b/recipes-core/base-files/base-files/mtcap/fstab
index 01b5f38..01b5f38 100644
--- a/recipes-core/base-files/base-files/mtp/fstab
+++ b/recipes-core/base-files/base-files/mtcap/fstab
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
index f1ab005..0f0ae4f 100644
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
media_card="/media/card"
-media_card_mtp=""
+media_card_mtcap=""
# add SD card dir
dirs755_append = " ${media_card}"
diff --git a/recipes-core/images/mlinux-base-image.bb b/recipes-core/images/mlinux-base-image.bb
index 35a58a9..6423237 100644
--- a/recipes-core/images/mlinux-base-image.bb
+++ b/recipes-core/images/mlinux-base-image.bb
@@ -51,6 +51,7 @@ MULTITECH_FEATURES += " \
reset-handler \
radio-cmd radio-query \
jsparser \
+ annex-client \
"
MISC_FEATURES = "minicom lrzsz nano rs9113"
diff --git a/recipes-core/images/mlinux-mtcap-debug-image.bb b/recipes-core/images/mlinux-mtcap-debug-image.bb
new file mode 100644
index 0000000..48009ae
--- /dev/null
+++ b/recipes-core/images/mlinux-mtcap-debug-image.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "mLinux Conduit Access Point debug image"
+
+require mlinux-mtcap-image.bb
+
+# Extra stuff to install
+IMAGE_INSTALL += "lora-network-server-mtcap \
+ lora-gateway-utils \
+ lora-query \
+ mosquitto mosquitto-clients \
+ nodejs \
+ nodejs-npm \
+ "
+
diff --git a/recipes-core/images/mlinux-picocell-image.bb b/recipes-core/images/mlinux-mtcap-image.bb
index 49670a9..610fe08 100644
--- a/recipes-core/images/mlinux-picocell-image.bb
+++ b/recipes-core/images/mlinux-mtcap-image.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "mLinux PicoCell image"
+DESCRIPTION = "mLinux Conduit Access Point image"
require mlinux-minimal-image.bb
@@ -32,6 +32,8 @@ MULTITECH_FEATURES += " \
reset-handler \
radio-cmd radio-query \
jsparser \
+ protobuf \
+ annex-client \
"
LORA_FEATURES = "lora-packet-forwarder \
diff --git a/recipes-core/images/mlinux-picocell-debug-image.bb b/recipes-core/images/mlinux-picocell-debug-image.bb
deleted file mode 100644
index 9ae7ea7..0000000
--- a/recipes-core/images/mlinux-picocell-debug-image.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "mLinux PicoCell debug image"
-
-require mlinux-picocell-image.bb
-
-# Extra stuff to install
-IMAGE_INSTALL += "lora-network-server-mtp \
- lora-gateway-utils \
- lora-query \
- mosquitto mosquitto-clients"
-
diff --git a/recipes-core/udev/udev-182/mtp/mtp.rules b/recipes-core/udev/udev-182/mtcap/mtcap.rules
index a0dc9fb..a0dc9fb 100644
--- a/recipes-core/udev/udev-182/mtp/mtp.rules
+++ b/recipes-core/udev/udev-182/mtcap/mtcap.rules