summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2016-09-14 21:30:12 +0300
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2016-09-14 21:30:12 +0300
commitad4cb1501c9ac3c364f1b5cf26fdfb5283d9c8ba (patch)
tree84c9cfe673bb353f15824682d5a59df5aaf22da1 /recipes-core
parent1a1588a159e8284d45df6cc4b1b8fb68dafe792c (diff)
downloadmeta-mlinux-atmel-ad4cb1501c9ac3c364f1b5cf26fdfb5283d9c8ba.tar.gz
meta-mlinux-atmel-ad4cb1501c9ac3c364f1b5cf26fdfb5283d9c8ba.tar.bz2
meta-mlinux-atmel-ad4cb1501c9ac3c364f1b5cf26fdfb5283d9c8ba.zip
mtp: remove wifi and bt from the mlinux-picocell-image recipe
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/mlinux-picocell-image.bb56
1 files changed, 48 insertions, 8 deletions
diff --git a/recipes-core/images/mlinux-picocell-image.bb b/recipes-core/images/mlinux-picocell-image.bb
index 5814eab..d839260 100644
--- a/recipes-core/images/mlinux-picocell-image.bb
+++ b/recipes-core/images/mlinux-picocell-image.bb
@@ -1,11 +1,51 @@
-require mlinux-base-image.bb
+DESCRIPTION = "mLinux PicoCell image"
-# Multi-Tech SMS Utility (see http://git.multitech.net)
-IMAGE_INSTALL += "sms-utils"
+require mlinux-minimal-image.bb
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ "
+
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
-# LoRa
-IMAGE_INSTALL += "lora-packet-forwarder \
- lora-packet-forwarder-dbg"
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ "
-# MQTT server
-IMAGE_INSTALL += "mosquitto mosquitto-clients"
+LORA_FEATURES = "lora-packet-forwarder \
+ lora-packet-forwarder-dbg"
+
+MISC_FEATURES = "minicom lrzsz nano"
+
+# Extra stuff to install
+IMAGE_INSTALL += " \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${LORA_FEATURES} \
+ ${MISC_FEATURES} \
+ "
+
+# Multi-Tech SMS Utility (see http://git.multitech.net)
+IMAGE_INSTALL += "sms-utils"