summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-11-02 12:03:39 -0500
committerJason Reiss <jreiss@multitech.com>2016-11-02 12:03:39 -0500
commit9c90a258482fe28760c3de5cd87d59776194af02 (patch)
treed5356ff909159319c8643bcc4237984b9794745c /recipes-core
parent4a699900a468a228d8280eaea5e7c7f0bb63be05 (diff)
parentdf86df735d7e84feafae6d5f76d4cd6b473d77a5 (diff)
downloadmeta-mlinux-atmel-9c90a258482fe28760c3de5cd87d59776194af02.tar.gz
meta-mlinux-atmel-9c90a258482fe28760c3de5cd87d59776194af02.tar.bz2
meta-mlinux-atmel-9c90a258482fe28760c3de5cd87d59776194af02.zip
Merge branch 'Conduit_0.1' of gitlab.multitech.net:mirrors/meta-mlinux into Conduit_0.1
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/mlinux-xrs9113-base-image.bb65
-rw-r--r--recipes-core/images/mlinux-xrs9113-factory-image.bb83
2 files changed, 148 insertions, 0 deletions
diff --git a/recipes-core/images/mlinux-xrs9113-base-image.bb b/recipes-core/images/mlinux-xrs9113-base-image.bb
new file mode 100644
index 0000000..b90903a
--- /dev/null
+++ b/recipes-core/images/mlinux-xrs9113-base-image.bb
@@ -0,0 +1,65 @@
+DESCRIPTION = "mLinux base image"
+LICENSE = "MIT"
+
+require mlinux-minimal-image.bb
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ "
+
+WIFI_FEATURES = " \
+ libnl \
+ wpa-supplicant \
+ wireless-tools \
+ iw \
+ hostap-daemon hostap-utils \
+ "
+
+BLUETOOTH_FEATURES = "bluez4"
+
+# Add all timezones available
+# ntpdate will sync time every 30 min by default via cron
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+# u-boot-linux-utils: U-Boot environment access from Linux
+# mlinux-scripts: sample scripts for setting up Conduit for various tasks
+# reset-handler: default reset button handler
+# radio-cmd: supports cellular radio activation and other configuration commands
+# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
+# jsparser: command line tool to parse JSON files
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ "
+
+MISC_FEATURES = "minicom lrzsz nano"
+
+# Extra stuff to install
+IMAGE_INSTALL += " \
+ ${WIFI_FEATURES} \
+ ${BLUETOOTH_FEATURES} \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${MISC_FEATURES} \
+ "
diff --git a/recipes-core/images/mlinux-xrs9113-factory-image.bb b/recipes-core/images/mlinux-xrs9113-factory-image.bb
new file mode 100644
index 0000000..fe2e698
--- /dev/null
+++ b/recipes-core/images/mlinux-xrs9113-factory-image.bb
@@ -0,0 +1,83 @@
+require mlinux-xrs9113-base-image.bb
+
+LIGHTTPD = "lighttpd \
+ lighttpd-module-cgi lighttpd-module-indexfile \
+ lighttpd-module-redirect lighttpd-module-auth \
+ lighttpd-module-access lighttpd-module-accesslog \
+ lighttpd-module-rewrite lighttpd-module-proxy lighttpd-module-fastcgi \
+ lighttpd-module-scgi lighttpd-module-alias \
+ lighttpd-module-dirlisting lighttpd-module-staticfile \
+ "
+
+# Lighttpd web server
+IMAGE_INSTALL += "${LIGHTTPD}"
+
+IMAGE_INSTALL += "sqlite3"
+
+IMAGE_INSTALL += "autossh"
+
+# Monit system/process monitor
+IMAGE_INSTALL += "monit"
+
+# LoRa support (MTAC-LORA accessory card)
+IMAGE_INSTALL += "lora-gateway-utils lora-network-server lora-query"
+
+# MQTT server
+IMAGE_INSTALL += "mosquitto mosquitto-clients"
+
+# Perl support
+IMAGE_INSTALL += "perl"
+IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
+# not in meta-oe or oe-core...
+#IMAGE_INSTALL += "libdevice-serialport-perl"
+#IMAGE_INSTALL += "libexpect-perl"
+
+# Python support
+IMAGE_INSTALL += "python"
+# Python modules
+IMAGE_INSTALL += "python-async \
+python-argparse \
+python-compression \
+python-dateutil \
+python-html \
+python-psutil \
+python-pycurl \
+python-pyopenssl \
+python-pyserial \
+python-pyudev \
+python-pyusb \
+python-simplejson \
+python-sqlite3 \
+python-syslog \
+python-textutils \
+python-unixadmin \
+python-xml \
+"
+
+# Ruby support
+IMAGE_INSTALL += "ruby"
+IMAGE_INSTALL += "ruby-sqlite3"
+IMAGE_INSTALL += "ruby-serialport"
+
+# OpenJDK Java runtime
+IMAGE_INSTALL += "openjdk-7-jre"
+# OpenJDK with JamVM VM (Multi-Tech default)
+IMAGE_INSTALL += "openjdk-7-vm-jamvm"
+# OpenJDK with CACAO VM (run with 'java -cacao')
+IMAGE_INSTALL += "openjdk-7-vm-cacao"
+# OpenJDK Zero VM (run with 'java -zero')
+IMAGE_INSTALL += "openjdk-7-vm-zero"
+
+# PHP support
+IMAGE_INSTALL += "php php-cli php-cgi"
+
+# Node.js support
+IMAGE_INSTALL += "nodejs nodejs-npm"
+
+# Multi-Tech SMS Utility (see http://git.multitech.net)
+IMAGE_INSTALL += "sms-utils"
+# Multi-Tech GPS Utility
+IMAGE_INSTALL += "venus-gps"
+
+IMAGE_INSTALL += "uvccapture"
+