summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-01-18 10:41:40 -0600
committerJohn Klug <john.klug@multitech.com>2017-01-18 10:41:40 -0600
commit62ae734de0cd4263c015a4979020d256eb9cde8a (patch)
tree8b35282cbe35b861b8164fa917160d24f5988018 /recipes-core
parenta55ba668fa18b75a00a8546a0408f90de39e7085 (diff)
downloadmeta-mlinux-atmel-62ae734de0cd4263c015a4979020d256eb9cde8a.tar.gz
meta-mlinux-atmel-62ae734de0cd4263c015a4979020d256eb9cde8a.tar.bz2
meta-mlinux-atmel-62ae734de0cd4263c015a4979020d256eb9cde8a.zip
rs9113 factory image to contain the mlinux factory image
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/mlinux-factory-image.bb1
-rw-r--r--recipes-core/images/mlinux-rs9113-base-image.bb4
-rw-r--r--recipes-core/images/mlinux-rs9113-factory-image.bb87
3 files changed, 7 insertions, 85 deletions
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index b8d2676..c50619b 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -1,5 +1,6 @@
# Conduit 0.0 or 0.1 without RS9113
require mlinux-base-image.bb
+DESCRIPTION = "mLinux factory image"
LIGHTTPD = "lighttpd \
lighttpd-module-cgi lighttpd-module-indexfile \
diff --git a/recipes-core/images/mlinux-rs9113-base-image.bb b/recipes-core/images/mlinux-rs9113-base-image.bb
index a4e9f23..78f604f 100644
--- a/recipes-core/images/mlinux-rs9113-base-image.bb
+++ b/recipes-core/images/mlinux-rs9113-base-image.bb
@@ -1,5 +1,5 @@
-require mlinux-base-image.bb
-DESCRIPTION = "mLinux base image"
+require mlinux-rs9113-base-image.bb
+DESCRIPTION = "mLinux base image with rs9113 drivers"
# Extra stuff to install
IMAGE_INSTALL += " rs9113 "
diff --git a/recipes-core/images/mlinux-rs9113-factory-image.bb b/recipes-core/images/mlinux-rs9113-factory-image.bb
index bf2beaa..3fe2ca6 100644
--- a/recipes-core/images/mlinux-rs9113-factory-image.bb
+++ b/recipes-core/images/mlinux-rs9113-factory-image.bb
@@ -1,84 +1,5 @@
-require mlinux-rs9113-base-image.bb
+require mlinux-factory-image.bb
+DESCRIPTION = "mLinux factory image with rs9113 drivers"
-LIGHTTPD = "lighttpd \
- lighttpd-module-cgi lighttpd-module-indexfile \
- lighttpd-module-redirect lighttpd-module-auth \
- lighttpd-module-access lighttpd-module-accesslog \
- lighttpd-module-rewrite lighttpd-module-proxy lighttpd-module-fastcgi \
- lighttpd-module-scgi lighttpd-module-alias \
- lighttpd-module-dirlisting lighttpd-module-staticfile \
- "
-
-# Lighttpd web server
-IMAGE_INSTALL += "${LIGHTTPD}"
-
-IMAGE_INSTALL += "sqlite3"
-
-IMAGE_INSTALL += "autossh"
-
-# Monit system/process monitor
-IMAGE_INSTALL += "monit"
-
-# LoRa support (MTAC-LORA accessory card)
-IMAGE_INSTALL += "lora-gateway-utils lora-network-server lora-query"
-
-# MQTT server
-IMAGE_INSTALL += "mosquitto mosquitto-clients"
-
-# Perl support
-IMAGE_INSTALL += "perl"
-IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
-# not in meta-oe or oe-core...
-#IMAGE_INSTALL += "libdevice-serialport-perl"
-#IMAGE_INSTALL += "libexpect-perl"
-
-# Python support
-IMAGE_INSTALL += "python"
-# Python modules
-IMAGE_INSTALL += "python-async \
-python-argparse \
-python-compression \
-python-dateutil \
-python-html \
-python-psutil \
-python-pycurl \
-python-pyopenssl \
-python-pyserial \
-python-pyudev \
-python-pyusb \
-python-simplejson \
-python-sqlite3 \
-python-syslog \
-python-textutils \
-python-unixadmin \
-python-xml \
-"
-
-# Ruby support
-IMAGE_INSTALL += "ruby"
-IMAGE_INSTALL += "ruby-sqlite3"
-IMAGE_INSTALL += "ruby-serialport"
-
-# OpenJDK Java runtime
-IMAGE_INSTALL += "openjdk-7-jre"
-# OpenJDK with JamVM VM (Multi-Tech default)
-IMAGE_INSTALL += "openjdk-7-vm-jamvm"
-# OpenJDK with CACAO VM (run with 'java -cacao')
-IMAGE_INSTALL += "openjdk-7-vm-cacao"
-# OpenJDK Zero VM (run with 'java -zero')
-IMAGE_INSTALL += "openjdk-7-vm-zero"
-
-# PHP support
-IMAGE_INSTALL += "php php-cli php-cgi"
-
-# Node.js support
-IMAGE_INSTALL += "nodejs nodejs-npm"
-
-# Multi-Tech SMS Utility (see http://git.multitech.net)
-IMAGE_INSTALL += "sms-utils"
-# Multi-Tech GPS Utility
-IMAGE_INSTALL += "venus-gps"
-IMAGE_INSTALL += "pps-tools"
-IMAGE_INSTALL += "gpsd"
-
-IMAGE_INSTALL += "uvccapture"
+# Extra stuff to install
+IMAGE_INSTALL += " rs9113 "