summaryrefslogtreecommitdiff
path: root/recipes-core/udev
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-08-16 16:01:13 -0500
committerJohn Klug <john.klug@multitech.com>2017-08-16 16:01:13 -0500
commit41b0a8e202a1ed05bdf061eb33d0bf3c18d61106 (patch)
treed7b0e0bb538e8b73d151ee2a15b3b1180a6f8773 /recipes-core/udev
parent82766143f4e215475517dc7d28e44d0363f58828 (diff)
downloadmeta-mlinux-atmel-41b0a8e202a1ed05bdf061eb33d0bf3c18d61106.tar.gz
meta-mlinux-atmel-41b0a8e202a1ed05bdf061eb33d0bf3c18d61106.tar.bz2
meta-mlinux-atmel-41b0a8e202a1ed05bdf061eb33d0bf3c18d61106.zip
Upward compatibility for udev and /media
Diffstat (limited to 'recipes-core/udev')
-rw-r--r--recipes-core/udev/udev-extraconf/mount.patch17
-rw-r--r--recipes-core/udev/udev-extraconf_%.bbappend3
2 files changed, 17 insertions, 3 deletions
diff --git a/recipes-core/udev/udev-extraconf/mount.patch b/recipes-core/udev/udev-extraconf/mount.patch
index 5468295..16e0672 100644
--- a/recipes-core/udev/udev-extraconf/mount.patch
+++ b/recipes-core/udev/udev-extraconf/mount.patch
@@ -1,6 +1,6 @@
diff -Naru old/mount.sh new/mount.sh
---- old/mount.sh 2017-07-13 14:38:01.497487772 -0500
-+++ new/mount.sh 2017-07-19 17:18:08.749856242 -0500
+--- old/mount.sh 2017-08-16 15:14:20.386456313 -0500
++++ new/mount.sh 2017-08-16 15:21:28.898443627 -0500
@@ -4,7 +4,6 @@
#
# Attempt to mount any added block devices and umount any removed devices
@@ -9,7 +9,18 @@ diff -Naru old/mount.sh new/mount.sh
MOUNT="/bin/mount"
PMOUNT="/usr/bin/pmount"
UMOUNT="/bin/umount"
-@@ -66,7 +65,11 @@
+@@ -21,6 +20,10 @@
+ name="`basename "$DEVNAME"`"
+
+ ! test -d "/run/media/$name" && mkdir -p "/run/media/$name"
++ if [ "$name" = mmcblk0p1 ] ;
++ then
++ ln -sf /run/media/$name /run/media/card
++ fi
+ # Silent util-linux's version of mounting auto
+ if [ "x`readlink $MOUNT`" = "x/bin/mount.util-linux" ] ;
+ then
+@@ -66,7 +69,11 @@
if [ -x "$PMOUNT" ]; then
$PMOUNT $DEVNAME 2> /dev/null
elif [ -x $MOUNT ]; then
diff --git a/recipes-core/udev/udev-extraconf_%.bbappend b/recipes-core/udev/udev-extraconf_%.bbappend
index 6d4804d..708a07c 100644
--- a/recipes-core/udev/udev-extraconf_%.bbappend
+++ b/recipes-core/udev/udev-extraconf_%.bbappend
@@ -1,2 +1,5 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PR = "m1"
+
+SRC_URI += "file://mount.patch"