summaryrefslogtreecommitdiff
path: root/recipes-core/udev/eudev_%.bbappend
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-10-31 14:46:37 -0500
committerJohn Klug <john.klug@multitech.com>2023-05-24 16:28:46 -0500
commitb896db61b5da7f117beea0ad783359e85a5a0f29 (patch)
tree9696f3fc8547d23a9f13754d3b46d4e831ed5e14 /recipes-core/udev/eudev_%.bbappend
parentc26ad9368a1ff1513448ec83d760b9204d0dda3b (diff)
downloadmeta-mlinux-atmel-b896db61b5da7f117beea0ad783359e85a5a0f29.tar.gz
meta-mlinux-atmel-b896db61b5da7f117beea0ad783359e85a5a0f29.tar.bz2
meta-mlinux-atmel-b896db61b5da7f117beea0ad783359e85a5a0f29.zip
Linux 5.4 MTAC Ethernet fix so AP1 is eth1 and AP2 is eth2
Diffstat (limited to 'recipes-core/udev/eudev_%.bbappend')
-rw-r--r--recipes-core/udev/eudev_%.bbappend5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index 446ad6e..772ab33 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,13 +1,16 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PR .= ".mlinux11"
+PR .= ".mlinux12"
SRC_URI_append_mtcdt = " \
file://accessory_ethernet.rules \
+ file://mtcdt_eth_rename.sh \
file://mtcdt-atmel-serial.rules \
"
do_install_append_mtcdt() {
install -m 644 ${WORKDIR}/accessory_ethernet.rules ${D}${sysconfdir}/udev/rules.d/
install -m 644 ${WORKDIR}/mtcdt-atmel-serial.rules ${D}${sysconfdir}/udev/rules.d/
+ install -d 755 ${D}${sysconfdir}/udev/scripts/
+ install -m 755 ${WORKDIR}/mtcdt_eth_rename.sh ${D}${sysconfdir}/udev/scripts/
}