summaryrefslogtreecommitdiff
path: root/recipes-core/mlinux-scripts
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-08-25 18:19:21 -0500
committerJohn Klug <john.klug@multitech.com>2017-09-14 17:28:04 -0500
commit3f4db168d33bf20eef0b00ee7404c1868a724371 (patch)
tree54ab55eec4f19bfdd17caf7e01911fd678f18748 /recipes-core/mlinux-scripts
parent3f4c6b48c132ed82ea7e93fdd69e6bdf52feb591 (diff)
downloadmeta-mlinux-atmel-3f4db168d33bf20eef0b00ee7404c1868a724371.tar.gz
meta-mlinux-atmel-3f4db168d33bf20eef0b00ee7404c1868a724371.tar.bz2
meta-mlinux-atmel-3f4db168d33bf20eef0b00ee7404c1868a724371.zip
Update mlinux-set-apn for Verizon, and for LNA3 radio.
Diffstat (limited to 'recipes-core/mlinux-scripts')
-rwxr-xr-xrecipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-set-apn44
-rwxr-xr-xrecipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-cell-router (renamed from recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-cell-router)0
-rwxr-xr-xrecipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-dhcpd (renamed from recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-dhcpd)0
-rwxr-xr-xrecipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-firmware-upgrade (renamed from recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-firmware-upgrade)0
-rwxr-xr-xrecipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-set-apn105
-rwxr-xr-xrecipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-wifi-ap (renamed from recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-wifi-ap)0
-rw-r--r--recipes-core/mlinux-scripts/mlinux-scripts.inc (renamed from recipes-core/mlinux-scripts/mlinux-scripts-1.0.inc)0
-rw-r--r--recipes-core/mlinux-scripts/mlinux-scripts_1.1.bb (renamed from recipes-core/mlinux-scripts/mlinux-scripts_1.0.bb)4
8 files changed, 107 insertions, 46 deletions
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-set-apn b/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-set-apn
deleted file mode 100755
index 85839f8..0000000
--- a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-set-apn
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/bash
-
-# Copyright (C) 2014 Multi-Tech Systems
-
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-# THE SOFTWARE.
-
-if [[ $# != 1 ]]; then
- echo "Usage: $(basename $0) APN"
- exit 1
-fi
-
-apn=$1
-gsm_chat_file=/etc/ppp/peers/gsm_chat
-lvw2_chat_file=/etc/ppp/peers/lvw2_chat
-leu1_chat_file=/etc/ppp/peers/leu1_chat
-
-sed -r -i "s/^OK\s+'AT\+CGDCONT=1,\"IP\",\"[^\"]*\"'$/OK 'AT\+CGDCONT=1,\"IP\",\"${apn}\"'/" $gsm_chat_file
-sed -r -i "s/^OK\s+'AT\+CGDCONT=3,\"IPV4V6\",\"[^\"]*\"'$/OK 'AT\+CGDCONT=3,\"IPV4V6\",\"${apn}\"'/" $lvw2_chat_file
-sed -r -i "s/^OK\s+'AT\+CGDCONT=1,\"IPV4V6\",\"[^\"]*\"'$/OK 'AT\+CGDCONT=1,\"IPV4V6\",\"${apn}\"'/" $leu1_chat_file
-
-if [[ $? != 0 ]]; then
- echo "Failed to change APN"
- exit 1
-else
- echo "Set APN to \"${apn}\" in $gsm_chat_file, $lvw2_chat_file and $leu1_chat_file"
-fi
-
-exit 0
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-cell-router b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-cell-router
index 1607c32..1607c32 100755
--- a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-cell-router
+++ b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-cell-router
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-dhcpd b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-dhcpd
index 976b138..976b138 100755
--- a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-dhcpd
+++ b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-dhcpd
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-firmware-upgrade b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-firmware-upgrade
index 94027d5..94027d5 100755
--- a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-firmware-upgrade
+++ b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-firmware-upgrade
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-set-apn b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-set-apn
new file mode 100755
index 0000000..0935542
--- /dev/null
+++ b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-set-apn
@@ -0,0 +1,105 @@
+#!/bin/bash
+
+# Copyright (C) 2014,2017 Multi-Tech Systems
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+function usage {
+ echo "Usage: $(basename $0) [--] APN"
+ echo "Or $(basename $0) -c to clear the APN line"
+ echo "-- is requied if the APN begins with -"
+ exit 1
+}
+
+((clear=0))
+if (($# < 1)); then
+ usage
+fi
+if [[ $1 == "--" ]] ; then
+ apn=$2
+elif [[ $1 == "-c" ]] ; then
+ clear=1
+elif [[ $1 =~ ^- ]] ; then
+ usage
+else
+ apn=$1
+fi
+gsm_chat_file=/etc/ppp/peers/gsm_chat
+lvw2_chat_file=/etc/ppp/peers/lvw2_chat
+leu1_chat_file=/etc/ppp/peers/leu1_chat
+lna3_chat_file=/etc/ppp/peers/lna3_chat
+echo clear is $clear
+
+model=$(radio-query --model 2>/dev/null)
+
+if [[ $model == "LE910-NA1" ]] ; then
+ if ((clear != 1)) ; then
+ if sed -r -i "s/^(#comment by mlinux-set-apn )*OK\s+'AT\+CGDCONT=3,\"IPV4V6\",\"[^\"]*\"'$/OK 'AT\+CGDCONT=3,\"IPV4V6\",\"${apn}\"'/" $lna3_chat_file ; then
+ echo "Set APN to \"${apn}\" in $lna3_chat_file"
+ else
+ echo "Failed to set APN in $lna3_chat_file"
+ fi
+ fw=$(radio-query --active-firmware 2>/dev/null) || ((fw=-1))
+ if (( fw == 1 )) ; then
+ # Verizon is active, so comment out the APN
+ echo "Temporarily commenting out APN, since Verizon is active and no APN is allowed in a Verizon chat file."
+ sed -r -i "s/^(OK\s+'AT\+CGDCONT=3,\"IPV4V6\",\"[^\"]*\"'$)/#comment by mlinux-set-apn \1/" $lna3_chat_file
+ fi
+ else
+ if sed -r -i "s/^(OK\s+'AT\+CGDCONT=3,\"IPV4V6\",\"[^\"]*\"'$)/#comment by mlinux-set-apn \1/" $lna3_chat_file ; then
+ echo "Commented out APN in $lna3_chat_file"
+ else
+ echo "Failed to comment out APN in $lna3_chat_file"
+ fi
+ fi
+ exit 0
+fi
+
+
+if ((clear != 1)) ; then
+ if sed -r -i "s/^(#comment by mlinux-set-apn )*OK\s+'AT\+CGDCONT=1,\"IP\",\"[^\"]*\"'$/OK 'AT\+CGDCONT=1,\"IP\",\"${apn}\"'/" $gsm_chat_file ; then
+ echo "Set APN to \"${apn}\" in $gsm_chat_file"
+ else
+ echo "Failed to set APN in $gsm_chat_file"
+ fi
+ echo "Not allowed to set APN for $lvw2_chat_file"
+ # We cannot set the APN for a Verizon modem
+ # sed -r -i "s/^(#comment by mlinux-set-apn )*OK\s+'AT\+CGDCONT=3,\"IPV4V6\",\"[^\"]*\"'$/OK 'AT\+CGDCONT=3,\"IPV4V6\",\"${apn}\"'/" $lvw2_chat_file
+ if sed -r -i "s/^(#comment by mlinux-set-apn )*OK\s+'AT\+CGDCONT=1,\"IPV4V6\",\"[^\"]*\"'$/OK 'AT\+CGDCONT=1,\"IPV4V6\",\"${apn}\"'/" $leu1_chat_file ; then
+ echo "Set APN to \"${apn}\" in $leu1_chat_file"
+ else
+ echo "Failed to set APN in $leu1_chat_file"
+ fi
+else
+ if sed -r -i "s/^(OK\s+'AT\+CGDCONT=1,\"IP\",\"[^\"]*\"'$)/#comment by mlinux-set-apn \1/" $gsm_chat_file ; then
+ echo "Commented out APN in $gsm_chat_file"
+ else
+ echo "Failed to comment out APN in $gsm_chat_file"
+ fi
+ # Not setting APN in lvw2 is OK, since Verizon should not have an APN in a chat file.
+ if sed -r -i "s/^(OK\s+'AT\+CGDCONT=3,\"IPV4V6\",\"[^\"]*\"'$)/#comment by mlinux-set-apn \1/" $lvw2_chat_file ; then
+ echo "Commented out APN in $lvw2_chat_file"
+ fi
+ if sed -r -i "s/^(OK\s+'AT\+CGDCONT=1,\"IPV4V6\",\"[^\"]*\"'$)/#comment by mlinux-set-apn \1/" $leu1_chat_file ; then
+ echo "Commented out APN in $leu1_chat_file"
+ else
+ echo "Failed to comment out APN in $leu1_chat_file"
+ fi
+fi
+exit 0
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-wifi-ap b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-wifi-ap
index ddbec95..ddbec95 100755
--- a/recipes-core/mlinux-scripts/mlinux-scripts-1.0/mlinux-wifi-ap
+++ b/recipes-core/mlinux-scripts/mlinux-scripts-1.1/mlinux-wifi-ap
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts-1.0.inc b/recipes-core/mlinux-scripts/mlinux-scripts.inc
index 0f5c136..0f5c136 100644
--- a/recipes-core/mlinux-scripts/mlinux-scripts-1.0.inc
+++ b/recipes-core/mlinux-scripts/mlinux-scripts.inc
diff --git a/recipes-core/mlinux-scripts/mlinux-scripts_1.0.bb b/recipes-core/mlinux-scripts/mlinux-scripts_1.1.bb
index 9fb8fbd..05c1b84 100644
--- a/recipes-core/mlinux-scripts/mlinux-scripts_1.0.bb
+++ b/recipes-core/mlinux-scripts/mlinux-scripts_1.1.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Scripts to easily get started with common mLinux use cases"
-require mlinux-scripts-1.0.inc
+require mlinux-scripts.inc
-PR = "r5"
+PR = "r1"
S = "${WORKDIR}/mlinux-scripts-${PV}"