summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-09-13 13:50:35 -0500
committerBrandon Bayer <bbayer@multitech.com>2016-09-13 15:31:03 -0500
commitff2c2fdc5f98cd42c73906211bed0f35372a2445 (patch)
tree9dbc6bc26b8ba155d0e099c78fbcb351aacc79b0 /recipes-connectivity
parent22715646980f87f5ab5f70e2522525efa2f5f817 (diff)
downloadmeta-mlinux-atmel-ff2c2fdc5f98cd42c73906211bed0f35372a2445.tar.gz
meta-mlinux-atmel-ff2c2fdc5f98cd42c73906211bed0f35372a2445.tar.bz2
meta-mlinux-atmel-ff2c2fdc5f98cd42c73906211bed0f35372a2445.zip
picocell:feat: add lora packet-forwarder 3.0.0
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
new file mode 100644
index 0000000..ba5aa40
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "LoRa Packet Forwarder"
+HOMEPAGE = "https://github.com/Lora-net/packet_forwarder"
+PRIORITY = "optional"
+SECTION = "console/utils"
+# Semtech license is a modified BSD-style license
+LICENSE = "SEMTECH"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
+DEPENDS = "lora-gateway"
+PR = "r0"
+
+SRCREV = "v${PV}"
+
+SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
+ file://README.md \
+"
+
+S = "${WORKDIR}/git"
+
+LORA_DIR = "/opt/lora"
+
+export LGW_PATH = "${STAGING_LIBDIR}/lora"
+export LGW_INC = "${STAGING_INCDIR}/lora"
+
+CFLAGS += "-I${LGW_INC} -Iinc -I."
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 755 lora_pkt_fwd/lora_pkt_fwd ${D}${LORA_DIR}/
+ install -m 755 lora_pkt_fwd/cfg/global_conf.json.PCB_E336.EU868.basic ${D}${LORA_DIR}/global_conf.json
+
+ install -m 755 util_sink/util_sink ${D}${LORA_DIR}/
+ install -m 755 util_ack/util_ack ${D}${LORA_DIR}/
+ install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
+}
+
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}