summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-07-26 17:38:09 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:20 +0300
commit999abcdce63816b80d5de39f3d24d4cac19321d2 (patch)
treed8abbb554dacea571ff14781ddb26fe859f94b8f /recipes-connectivity
parent9eae394829275a701ef15bd8f6730667dcaf20be (diff)
downloadmeta-mlinux-atmel-999abcdce63816b80d5de39f3d24d4cac19321d2.tar.gz
meta-mlinux-atmel-999abcdce63816b80d5de39f3d24d4cac19321d2.tar.bz2
meta-mlinux-atmel-999abcdce63816b80d5de39f3d24d4cac19321d2.zip
Merge branch 'multiarch5' into multiarch5-thud, with up to date LoRa recipes.
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.2.27.bb (renamed from recipes-connectivity/lora/lora-network-server_2.2.18.bb)11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_2.2.18.bb b/recipes-connectivity/lora/lora-network-server_2.2.27.bb
index a0442d9..e579667 100644
--- a/recipes-connectivity/lora/lora-network-server_2.2.18.bb
+++ b/recipes-connectivity/lora/lora-network-server_2.2.27.bb
@@ -8,13 +8,13 @@ RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging"
PR = "r8"
CONFFILES_${PN} += "${sysconfdir}/default/lora-network-server ${sysconfdir}/init.d/lora-network-server"
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
file://lora-network-server.init \
file://lora-network-server.default \
"
-SRC_URI[md5sum] = "b774c019f2e6f2ff684fd51e62de81aa"
-SRC_URI[sha256sum] = "18b1a07b43da70b9a6bdee2c9fdd547af3e924099791aedef138cb13c1027a4e"
+SRC_URI[md5sum] = "ba431288ea2ad99e7558cfb8c66cfc8d"
+SRC_URI[sha256sum] = "07a9282905b2461437b116dfad58abd948f3a3e180f3fbf9fdaeab93e3632bdf"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
@@ -31,9 +31,12 @@ inherit update-rc.d
INITSCRIPT_NAME = "lora-network-server"
INITSCRIPT_PARAMS = "defaults 80 30"
+NETWORK_SERVER_VERSION_mtbsp-at91 = "4"
+NETWORK_SERVER_VERSION_mtbsp-ti = "5"
+
do_install() {
install -d ${D}${LORA_DIR}
- install -m 0755 lora-network-server-mlinux-4 ${D}${LORA_DIR}/lora-network-server
+ install -m 0755 lora-network-server-mlinux-${NETWORK_SERVER_VERSION} ${D}${LORA_DIR}/lora-network-server
install -m 0755 lora-v21-keygen ${D}${LORA_DIR}/lora-v21-keygen
install -m 0644 config/lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
install -m 0644 config/lora-network-server.conf.full ${D}${LORA_DIR}/lora-network-server.conf.full