summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-10-19 15:48:15 -0500
committerBrandon Bayer <bbayer@multitech.com>2016-10-19 17:10:44 -0500
commit6a9a67e34aca63caff77fd2f430cdbeaa1be3551 (patch)
treef048787def1aa4a3344c1c880c80fc9df2e31164 /recipes-connectivity
parent8000c124387080ddf9cb8b64402eb93961a531a6 (diff)
downloadmeta-mlinux-atmel-6a9a67e34aca63caff77fd2f430cdbeaa1be3551.tar.gz
meta-mlinux-atmel-6a9a67e34aca63caff77fd2f430cdbeaa1be3551.tar.bz2
meta-mlinux-atmel-6a9a67e34aca63caff77fd2f430cdbeaa1be3551.zip
mtp:feat: update lora-network-server-mtp to 1.0.14
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf35
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtp_1.0.14.bb (renamed from recipes-connectivity/lora/lora-network-server-mtp_1.0.13.bb)9
2 files changed, 40 insertions, 4 deletions
diff --git a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf b/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf
new file mode 100644
index 0000000..b018478
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf
@@ -0,0 +1,35 @@
+{
+ "lora": {
+ "netID": "010203", /* netID for beacon packets */
+ "frequencyBand": "868", /* US="915", EU="868" */
+ "rx1DatarateOffset": 0, /* Datarate offset for mote rx window 1 sent in join response (0-3) */
+ "rx2Datarate": 12, /* Datarate for mote rx window 2 sent in join response (7-12) */
+ "maxTxPower": 14, /* Max Tx power (dBm), -6 to 26 */
+ "frequencyEU": 867500000 /* center freq for extra EU channels (Hz) */
+ },
+ "udp": {
+ "appPortUp": 1784, /* port for user-developed application use */
+ "appPortDown": 1786, /* port for user-developed application use */
+ "upstreamPort": 1780, /* ports for LoRa network communication */
+ "downstreamPort": 1782 /* ports for LoRa network communication */
+ },
+ "addressRange": {
+ "start": "00:00:00:01", /* address range used for mDots */
+ "end": "FF:FF:FF:FE"
+ },
+ "network": {
+ "public": true, /* set to false for private LoRa network with mDots + Conduit */
+ "leasetime": 0, /* time until mDot join expires (minutes) or 0 for no expiration */
+ "name": "YOUR-NETWORK-NAME", /* configure network security */
+ "passphrase": "YOUR-NETWORK-PASSPHRASE"
+ },
+ "log" : {
+ "console" : true,
+ "syslog" : false,
+ "level" : 30, /* error=10, warn=20, info=30, debug=50, trace=60, max=100 */
+ "path": "/var/log/lora-network-server.log"
+ },
+ "mqtt": {
+ "enabled": true
+ }
+}
diff --git a/recipes-connectivity/lora/lora-network-server-mtp_1.0.13.bb b/recipes-connectivity/lora/lora-network-server-mtp_1.0.14.bb
index 898e2ec..2f5e0bf 100644
--- a/recipes-connectivity/lora/lora-network-server-mtp_1.0.13.bb
+++ b/recipes-connectivity/lora/lora-network-server-mtp_1.0.14.bb
@@ -9,15 +9,16 @@ DEPENDS = "jsoncpp libmts mosquitto sqlite3"
RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
PR = "r1"
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}-mtp.tar.gz \
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.conf \
file://lora-network-server.init \
file://lora-network-server.default \
file://lora-network-server.logrotate.conf \
file://local_conf.json \
"
-SRC_URI[md5sum] = "d21cab149a81938da7728f38d0baa3e4"
-SRC_URI[sha256sum] = "b1147b63ecd3afcfc259929c3f63a1dcb44b32c53ce0ebc7d8f0b59f465e0bf6"
+SRC_URI[md5sum] = "6cbae4e82503c5b5078b4ffadcda05a0"
+SRC_URI[sha256sum] = "707e919b02f1f7d3ef8ed66f26b7e8749f4d0db55288062f1aa4c04e5ceccf34"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
@@ -32,7 +33,7 @@ do_compile() {
do_install() {
install -d ${D}${LORA_DIR}
install -m 0755 lora-network-server ${D}${LORA_DIR}/
- install -m 0644 lora-network-server.conf ${D}${LORA_DIR}/
+ install -m 0644 ${WORKDIR}/lora-network-server.conf ${D}${LORA_DIR}/
install -m 0755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
install -d ${D}${sysconfdir}/default