summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2019-09-27 15:20:28 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:21 +0300
commit3ada7995d9654f5e43858e6bd25fba917b1d8f03 (patch)
tree74bf69ce7eea66ec0472d6c15803189f674520a5 /recipes-connectivity
parent67e43656ae8e790589777f5841671ec67c343ee2 (diff)
downloadmeta-mlinux-atmel-3ada7995d9654f5e43858e6bd25fba917b1d8f03.tar.gz
meta-mlinux-atmel-3ada7995d9654f5e43858e6bd25fba917b1d8f03.tar.bz2
meta-mlinux-atmel-3ada7995d9654f5e43858e6bd25fba917b1d8f03.zip
lora: update LNS to 2.2.36, remove lora-query RDEPENDS on jsoncpp
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.2.36.bb53
-rw-r--r--recipes-connectivity/lora/lora-query_1.0.4.bb1
2 files changed, 53 insertions, 1 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_2.2.36.bb b/recipes-connectivity/lora/lora-network-server_2.2.36.bb
new file mode 100644
index 0000000..7d85f04
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_2.2.36.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2b9a30a3082ddccd2c695a4dbeeab80d"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3 curl gnutls"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging"
+PR = "r0"
+CONFFILES_${PN} += "${sysconfdir}/default/lora-network-server ${sysconfdir}/init.d/lora-network-server"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ "
+
+SRC_URI[md5sum] = "22046bf935b02bc10798be8408a36439"
+SRC_URI[sha256sum] = "cee92d4a7070daac0571d85f2dc1251f8d7e1293569919229797a87eef099fca"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+NETWORK_SERVER_VERSION_mtbsp-at91 = "4"
+NETWORK_SERVER_VERSION_mtbsp-ti = "5"
+NS_ARCH_mtbsp-at91 = ""
+NS_ARCH_mtbsp-ti = "armv7ahf-"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server-${NS_ARCH}mlinux-${NETWORK_SERVER_VERSION} ${D}${LORA_DIR}/lora-network-server
+ install -m 0755 lora-v21-keygen ${D}${LORA_DIR}/lora-v21-keygen
+ install -m 0644 config/lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+ install -m 0644 config/lora-network-server.conf.full ${D}${LORA_DIR}/lora-network-server.conf.full
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+}
+
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"
diff --git a/recipes-connectivity/lora/lora-query_1.0.4.bb b/recipes-connectivity/lora/lora-query_1.0.4.bb
index 60bcc42..7f2b4b0 100644
--- a/recipes-connectivity/lora/lora-query_1.0.4.bb
+++ b/recipes-connectivity/lora/lora-query_1.0.4.bb
@@ -3,7 +3,6 @@ HOMEPAGE = "http://www.multitech.net/"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "jsoncpp libmts"
-RDEPENDS_${PN} += "jsoncpp"
PR = "r2"
SRCREV = "${PV}"