summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-04-13 15:39:17 -0500
committerJohn Klug <john.klug@multitech.com>2022-04-13 15:39:17 -0500
commitdb9f6cdee2da0518fb446a2039e19a07ef07fb73 (patch)
tree18330af40f6ae29bff250bbf008a29613e92990b
parent18eee52c9dd5ea45dbcad02d5ec5ab16cdebb81f (diff)
parent6d9482a1edc7db94f581e6103f7bab5b50b618b7 (diff)
downloadmeta-mlinux-atmel-db9f6cdee2da0518fb446a2039e19a07ef07fb73.tar.gz
meta-mlinux-atmel-db9f6cdee2da0518fb446a2039e19a07ef07fb73.tar.bz2
meta-mlinux-atmel-db9f6cdee2da0518fb446a2039e19a07ef07fb73.zip
Merge commit sel and mtrv1 images into 6
-rw-r--r--recipes-core/images/mlinux-mtrv1-image-copy.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/recipes-core/images/mlinux-mtrv1-image-copy.bb b/recipes-core/images/mlinux-mtrv1-image-copy.bb
new file mode 100644
index 0000000..847fea9
--- /dev/null
+++ b/recipes-core/images/mlinux-mtrv1-image-copy.bb
@@ -0,0 +1,82 @@
+require mtr-modules.inc
+DESCRIPTION = "mLinux base mtr image"
+LICENSE = "MIT"
+
+require mlinux-minimal-image.bb
+
+CONSOLE = "sysvinit-inittab-start-open"
+
+TEST_FEATURES = "i2c-tools \
+ spitools \
+ libgpiod-tools \
+ strace \
+ devmem2 \
+ "
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES_append = " bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf3 \
+ ppp-radioresetwait \
+ radio-reset-background \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ busybox-ifplugd \
+ "
+
+WIFI_FEATURES = " \
+ libnl \
+ wpa-supplicant \
+ iw \
+ hostapd \
+ hostapd-cfg \
+ "
+
+BLUETOOTH_FEATURES = "bluez5 bluez5-pand bluez5-mlinit"
+
+# Add all timezones available
+# ntpdate will sync time every 30 min by default via cron
+TIME_FEATURES = "tzdata-core tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+# u-boot-linux-utils: U-Boot environment access from Linux
+# mlinux-scripts: sample scripts for setting up Conduit for various tasks
+# reset-handler: default reset button handler
+# radio-cmd: supports cellular radio activation and other configuration commands
+# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
+# jsparser: command line tool to parse JSON files
+MULTITECH_FEATURES_append = " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ "
+
+MISC_FEATURES = "minicom lrzsz nano pps-tools"
+
+# Extra stuff to install
+IMAGE_INSTALL_append = " kernel-module-rs9113 rs9113-util rs9113-autostart"
+IMAGE_INSTALL_append = " gpsd gpsd-conf gpsd-gpsctl libgps ntp ntp-utils gpspipe gps-utils"
+
+IMAGE_INSTALL_append = " \
+ ${TEST_FEATURES} \
+ ${WIFI_FEATURES} \
+ ${BLUETOOTH_FEATURES} \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${MISC_FEATURES} \
+ "